an implementation of desktop bitcoin management system - Assign maintainership to port submitter Yuri Victorovich <yuri@rawbw.com> PR: 192367 Submitted by: Yuri Victorovich <yuri@rawbw.com> Approved by: mentors (implicit)
22 lines
565 B
Text
22 lines
565 B
Text
--- cppForSwig/cryptopp/Makefile
|
|
+++ cppForSwig/cryptopp/Makefile
|
|
@@ -105,6 +105,19 @@
|
|
M32OR64 = -m$(shell isainfo -b)
|
|
endif
|
|
|
|
+ifeq ($(UNAME),FreeBSD)
|
|
+AR = ar
|
|
+ARFLAGS = cr
|
|
+CXX ?= c++
|
|
+IS_GCC2 = $(shell $(CXX) -v 2>&1 | $(EGREP) -c gcc-932)
|
|
+ifeq ($(IS_GCC2),1)
|
|
+CXXFLAGS += -fno-coalesce-templates -fno-coalesce-static-vtables
|
|
+LDLIBS += -lstdc++
|
|
+LDFLAGS += -flat_namespace -undefined suppress -m
|
|
+endif
|
|
+endif
|
|
+
|
|
+
|
|
ifneq ($(IS_SUN_CC),0) # override flags for CC Sun C++ compiler
|
|
CXXFLAGS = -DNDEBUG -O -g0 -native -template=no%extdef $(M32OR64)
|
|
LDFLAGS =
|