69d0a0a258
Since Mark Crispin left the UW, development on UW-IMAP paused. Mark however continued developing the toolkit under the name Panda-IMAP. Since Mark passed, Jonathan Abbey created a project on GitHub, by concatenating all of the public releases of UW IMAP with the last version of Panda IMAP. Add conflict lines with the original ports.
152 lines
4 KiB
Text
152 lines
4 KiB
Text
--- src/osdep/unix/Makefile.orig 2013-06-21 23:29:17.000000000 +0200
|
|
+++ src/osdep/unix/Makefile 2014-12-01 22:35:23.000000000 +0100
|
|
@@ -30,9 +30,9 @@
|
|
|
|
EXTRAAUTHENTICATORS=
|
|
EXTRADRIVERS=mbox
|
|
-PASSWDTYPE=std
|
|
-SSLTYPE=nopwd
|
|
-IP=4
|
|
+PASSWDTYPE=pam
|
|
+SSLTYPE=unix.nopwd
|
|
+IP=6
|
|
|
|
|
|
# The optimization level here for GCC ports is set here for a reason. It's
|
|
@@ -56,13 +56,13 @@
|
|
|
|
# Extended flags needed for SSL. You may need to modify.
|
|
|
|
-SSLDIR=/usr/local/ssl
|
|
-SSLCERTS=$(SSLDIR)/certs
|
|
+#SSLDIR=/usr/local/ssl
|
|
+SSLCERTS=$(PREFIX)/certs
|
|
SSLKEYS=$(SSLCERTS)
|
|
SSLINCLUDE=$(SSLDIR)/include
|
|
SSLLIB=$(SSLDIR)/lib
|
|
|
|
-SSLCRYPTO=-lcrypto
|
|
+SSLCRYPTO=-lcrypto -lcrypt
|
|
|
|
# Older versions of MIT Kerberos also have a libcrypto. If so, you may need
|
|
# to use this instead
|
|
@@ -89,7 +89,7 @@
|
|
# AFSLDFLAGS may also need -L/usr/ucblib -lucb
|
|
DCECFLAGS= -DDCE_MINIMAL -DPASSWD_OVERRIDE=\"/opt/pop3/passwd/passwd\"
|
|
DCELDFLAGS= -ldce
|
|
-PAMLDFLAGS= -lpam -ldl
|
|
+PAMLDFLAGS= # -lpam -lcrypt
|
|
|
|
|
|
# Build parameters normally set by the individual port
|
|
@@ -132,7 +132,7 @@
|
|
# Commands possibly overriden by the individual port
|
|
|
|
ARRC=ar rc
|
|
-CC=cc
|
|
+#CC=cc
|
|
LN=ln -s
|
|
RANLIB=ranlib
|
|
|
|
@@ -156,7 +156,7 @@
|
|
dummy.o pseudo.o netmsg.o flstring.o fdstring.o \
|
|
rfc822.o nntp.o smtp.o imap4r1.o pop3.o \
|
|
unix.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o mix.o
|
|
-CFLAGS=-g
|
|
+CFLAGS+=$(BASECFLAGS) $(EXTRACFLAGS)
|
|
|
|
CAT=cat
|
|
MAKE=make
|
|
@@ -173,6 +173,10 @@
|
|
PASSWDTYPE=$(PASSWDTYPE) SSLTYPE=$(SSLTYPE) IP=$(IP)
|
|
|
|
|
|
+# Need this for the shared library rule to work correctly
|
|
+.SUFFIXES: .o .so
|
|
+SOFILES=${BINARIES:.o=.so}
|
|
+
|
|
# Here if no make argument established
|
|
|
|
missing: osdep.h
|
|
@@ -261,13 +265,14 @@
|
|
BASECFLAGS="-g -Dconst="
|
|
|
|
bsf: # FreeBSD
|
|
- $(BUILD) `$(CAT) SPECIALS` OS=$@ \
|
|
+ $(BUILD) `$(CAT) SPECIALS` OS=$@ CHECKPW=pam \
|
|
SIGTYPE=psx CRXTYPE=nfs \
|
|
SPOOLDIR=/var \
|
|
ACTIVEFILE=/usr/local/news/lib/active \
|
|
RSHPATH=/usr/bin/rsh \
|
|
+ LOCKPGM=$(PREFIX)/libexec/mlock \
|
|
BASECFLAGS="$(GCCCFLAGS)" \
|
|
- BASELDFLAGS="-lcrypt"
|
|
+ BASELDFLAGS="-lpam"
|
|
|
|
bsi: # BSD/i386
|
|
$(BUILD) `$(CAT) SPECIALS` OS=$@ \
|
|
@@ -863,23 +868,31 @@
|
|
|
|
# Build it!
|
|
|
|
-build: clean once $(ARCHIVE)
|
|
+build: clean once $(ARCHIVE) $(SHLIBNAME)
|
|
|
|
-all: $(ARCHIVE)
|
|
+all: $(ARCHIVE) $(SHLIBNAME)
|
|
|
|
$(ARCHIVE): $(BINARIES)
|
|
sh -c '$(RM) $(ARCHIVE) || true'
|
|
@$(CAT) ./ARCHIVE
|
|
@$(SH) ./ARCHIVE
|
|
|
|
+$(SHLIBNAME): $(SOFILES)
|
|
+ $(CC) -shared -Wl,-soname=$(SHLIBNAME) -o $(SHLIBNAME) $(SOFILES) `cat LDFLAGS`
|
|
+ $(LN) $(SHLIBNAME) lib$(SHLIBBASE).so
|
|
+
|
|
+.c.so: osdep.h
|
|
+ $(CC) -fPIC -DPIC -c `cat CFLAGS` ${@:.so=.c} -o $@
|
|
+
|
|
.c.o:
|
|
- `$(CAT) CCTYPE` -c `$(CAT) CFLAGS` $*.c
|
|
+ $(CC) -c `cat CFLAGS` $*.c
|
|
|
|
|
|
# Cleanup
|
|
|
|
clean:
|
|
sh -c '$(RM) auths.c crexcl.c ip_unix.c linkage.[ch] siglocal.c osdep*.[ch] *.o ARCHIVE *FLAGS *TYPE $(ARCHIVE) || true'
|
|
+ sh -c '$(RM) *.so $(SHLIBNAME)'
|
|
|
|
|
|
# Dependencies
|
|
@@ -914,7 +927,7 @@
|
|
|
|
# OS-dependent
|
|
|
|
-osdep.o:mail.h misc.h env.h fs.h ftl.h nl.h tcp.h \
|
|
+OSDEPS= mail.h misc.h env.h fs.h ftl.h nl.h tcp.h \
|
|
osdep.h env_unix.h tcp_unix.h \
|
|
osdep.c env_unix.c fs_unix.c ftl_unix.c nl_unix.c tcp_unix.c ip_unix.c\
|
|
auths.c crexcl.c flockcyg.c flocklnx.c flocksim.c fsync.c \
|
|
@@ -928,12 +941,19 @@
|
|
write.c sslstdio.c \
|
|
strerror.c strpbrk.c strstr.c strtok.c strtoul.c \
|
|
OSCFLAGS
|
|
+
|
|
+osdep.o: $(OSDEPS)
|
|
+ $(CC) `$(CAT) CFLAGS` `$(CAT) OSCFLAGS` -c osdep.c
|
|
+ @echo ========================================================================
|
|
@echo Building OS-dependent module
|
|
@echo If you get No such file error messages for files x509.h, ssl.h,
|
|
@echo pem.h, buffer.h, bio.h, and crypto.h, that means that OpenSSL
|
|
@echo is not installed on your system. Either install OpenSSL first
|
|
@echo or build with command: make `$(CAT) OSTYPE` SSLTYPE=none
|
|
- `$(CAT) CCTYPE` -c `$(CAT) CFLAGS` `$(CAT) OSCFLAGS` -c osdep.c
|
|
+ @echo ========================================================================
|
|
+
|
|
+osdep.so: $(OSDEPS)
|
|
+ $(CC) -fPIC -DPIC -c `$(CAT) CFLAGS` `$(CAT) OSCFLAGS` osdep.c -o $@
|
|
|
|
osdep.c: osdepbas.c osdepckp.c osdeplog.c osdepssl.c
|
|
$(CAT) osdepbas.c osdepckp.c osdeplog.c osdepssl.c > osdep.c
|