12c098aa05
Prayer is yet another Webmail interface for IMAP servers on Unix systems. It exists because we weren't terribly happy about the characteristics of existing Webmail interfaces: in particular scalability problems with common open source Webmail packages and the lack of flexibility that commercial packages would give us. This doesn't mean that Prayer is trying to compete with existing Webmail packages. It just means that Prayer is better suited to our particular environment. WWW: http://www-uxsup.csx.cam.ac.uk/~dpc22/prayer/
30 lines
1.3 KiB
Text
30 lines
1.3 KiB
Text
--- files/Makefile.orig Sun May 11 16:59:12 2003
|
|
+++ files/Makefile Tue Jan 6 10:33:33 2004
|
|
@@ -57,12 +57,12 @@
|
|
fi
|
|
|
|
install-config: etc/prayer.cf
|
|
- $(INSTALL) -D -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
|
|
- etc/prayer.cf ${BROOT}${PRAYER_CONFIG_FILE}
|
|
+ $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
|
|
+ etc/prayer.cf ${BROOT}${PRAYER_CONFIG_FILE}-dist
|
|
|
|
install-aconfig:
|
|
- $(INSTALL) -D -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
|
|
- etc/prayer-accountd.cf ${BROOT}${ACCOUNTD_CONFIG_FILE}
|
|
+ $(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
|
|
+ etc/prayer-accountd.cf ${BROOT}${ACCOUNTD_CONFIG_FILE}-dist
|
|
|
|
install-motd:
|
|
$(INSTALL) -o $(RO_USER) -g $(RO_GROUP) -m $(PUBLIC_FILE) \
|
|
@@ -82,8 +82,8 @@
|
|
BIN_DIR=$(BIN_DIR) INSTALL=$(INSTALL) \
|
|
./install.sh
|
|
if [ ! -f $(BROOT)$(PREFIX)/certs/prayer.pem ]; then $(MAKE) install-cert; fi
|
|
- if [ ! -f $(BROOT)$(PRAYER_CONFIG_FILE) ]; then $(MAKE) install-config; fi
|
|
- if [ ! -f $(BROOT)$(ACCOUNTD_CONFIG_FILE) ]; then $(MAKE) install-aconfig; fi
|
|
+ if [ ! -f $(BROOT)$(PRAYER_CONFIG_FILE)-dist ]; then $(MAKE) install-config; fi
|
|
+ if [ ! -f $(BROOT)$(ACCOUNTD_CONFIG_FILE)-dist ]; then $(MAKE) install-aconfig; fi
|
|
if [ ! -f $(BROOT)$(PREFIX)/etc/motd.html ]; then $(MAKE) install-motd; fi
|
|
if [ ! -f $(BROOT)$(PREFIX)/etc/welcome.html ]; then $(MAKE) install-welcome; fi
|
|
|