freebsd-ports/cad/chipmunk/files/patch-af
Martin Wilke 3e4ed01146 - Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG
- Remove X11BASE support in favor of LOCALBASE or PREFIX
- Use USE_LDCONFIG instead of INSTALLS_SHLIB
- Remove unneeded USE_GCC 3.4+

Thanks to all Helpers:
	Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr,
	ehaupt, nox, itetcu, flz, pav

PR:		116263
Tested on:	pointyhat
Approved by:	portmgr (pav)
2008-04-19 17:56:05 +00:00

65 lines
1.2 KiB
Text

--- mosis/Makefile.orig Tue Nov 4 22:19:13 2003
+++ mosis/Makefile Tue Dec 9 17:44:45 2003
@@ -23,6 +23,8 @@
#
#
+BINDIR = ${PREFIX}/bin
+
##
## (1) Choosing your compiler
## ---------------------------
@@ -47,7 +49,7 @@
##
-CC = gcc
+CC ?= gcc
##
## (2) If X isn't in the include path (the case for many MachTen and Linux
@@ -62,7 +64,7 @@
## or some other directory, depending on your installation. Use the
## first one for OS X.
-XINCLUDEDIR = .
+XINCLUDEDIR = ${LOCALBASE}/include
##
## If X isn't in the library path (the case for many MachTen and Linux
@@ -77,7 +79,7 @@
## depending on your installation. Use the second one for OS X.
##
-LIBX11 = -lX11
+LIBX11 = -lX11 -L${LOCALBASE}/lib
##
## (3) Adding appropriate flags
@@ -115,7 +117,7 @@
CHIPMUNKFLAGS =
-CFLAGS = $(CHIPMUNKFLAGS) -O -I../psys/include -I$(XINCLUDEDIR)
+CFLAGS += -DBSD -DF_OK -I../psys/include -I$(XINCLUDEDIR)
##
## (4) Library additions
@@ -123,7 +125,7 @@
##
## on some systems, -ldl must be added to the following line
-OTHERLIBS= -lm
+OTHERLIBS= -lm -lcompat
##
##
@@ -136,7 +138,7 @@
$(CC) -o mosis mosis.o $(LDFLAGS)
install: mosis
- cp mosis ../bin/mosis
+ ${BSD_INSTALL_PROGRAM} mosis $(BINDIR)
clean:
rm -f *.o mosis