- Switch to pytest4 - Add missing test-dependency on gpg - Remove unsupported pytest argument Reported by: reprise Approved by: portmgr blanket
11 lines
704 B
Text
11 lines
704 B
Text
--- tests/CMakeLists.txt.orig 2021-12-16 18:34:53 UTC
|
|
+++ tests/CMakeLists.txt
|
|
@@ -115,7 +115,7 @@ add_definitions(-DOQS_COMPILE_OPTIONS="[${OQS_COMPILE_
|
|
# for DLL builds.
|
|
add_custom_target(
|
|
run_tests
|
|
- COMMAND ${CMAKE_COMMAND} -E env OQS_BUILD_DIR=${CMAKE_BINARY_DIR} ${PYTHON3_EXEC} -m pytest --verbose --numprocesses=auto --ignore=scripts/copy_from_upstream/repos
|
|
+ COMMAND ${CMAKE_COMMAND} -E env OQS_BUILD_DIR=${CMAKE_BINARY_DIR} ${PYTHON3_EXEC} -m pytest --verbose --ignore=scripts/copy_from_upstream/repos
|
|
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
|
|
DEPENDS oqs example_kem kat_kem test_kem example_sig kat_sig test_sig test_sig_mem test_kem_mem ${UNIX_TESTS}
|
|
USES_TERMINAL)
|