freebsd-ports/biology/py-macs2/files/patch-setup.py
Jason W. Bacon bad93f9f14 biology/py-macs2: Upgrade to 2.2.7.1
Bug fix release

Reported by:    portscout
2020-04-14 12:13:55 +00:00

25 lines
1.1 KiB
Python

--- setup.py.orig 2020-04-12 14:46:03 UTC
+++ setup.py
@@ -26,22 +26,6 @@ def main():
cwd = os.path.abspath(os.path.dirname(__file__))
- # install required numpy
- p = subprocess.call([sys.executable, "-m", 'pip', 'install', f'numpy{numpy_requires}'],cwd=cwd)
- if p != 0:
- # Could be due to a too old pip version and build isolation, check that
- try:
- # Note, pip may not be installed or not have been used
- import pip
- if LooseVersion(pip.__version__) < LooseVersion('18.0.0'):
- raise RuntimeError("Installing requirements failed. Possibly due "
- "to `pip` being too old, found version {}, "
- "needed is >= 18.0.0.".format(pip.__version__))
- else:
- raise RuntimeError("Installing requirements failed!")
- except ImportError:
- raise RuntimeError("Installing requirement failed! `pip` has to be installed!")
-
from numpy import get_include as numpy_get_include
numpy_include_dir = [numpy_get_include()]