50cde3dbb3
- Move docs-related stuff to Makefile.doc - Better MPM handling (for slave ports) - Fix HTTP_PORT behaviour - Make suExec more configurable [1] - Now config script are regenerated by buildconfig, to improve slave ports support and minimize apr/apache2 ports conflict [2] - Fix typo in AUTH_MODULES routine [3] [4] - apr threaded support [5] - Fix Segmentation fault with LDAP [6] - Add db42 support. [7] (just uncomment related lines if you installed it from shar) - add SLAVE_DESIGNED_FOR variable for slave ports to automaticaly mark them as BROKEN, if they are out of sync with apache2 PRs: 60444 [1], 61030 [4] Requested by: Matthias Andree <matthias.andree@gmx.de> [7] Suggested by: kuriyama [2] [5] Submitted by: Daniel Tasov <danielt@pilgerer.org> [1], kuriyama [5], motoyuki [3], Scott Michel <scottm@cs.ucla.edu> [4] Obtained from: Apache CVS [6] Reviewed by: erwin, linimon Approved by: erwin (mentor)
33 lines
2 KiB
Text
33 lines
2 KiB
Text
--- configure.in.orig Mon Jan 5 14:40:31 2004
|
|
+++ configure.in Mon Jan 5 14:44:51 2004
|
|
@@ -69,7 +69,7 @@
|
|
|
|
if test "$apr_found" = "reconfig"; then
|
|
APR_SUBDIR_CONFIG(srclib/apr,
|
|
- [$apache_apr_flags --prefix=$prefix --exec-prefix=$exec_prefix --libdir=$libdir --includedir=$includedir --bindir=$bindir --datadir=$datadir --with-installbuilddir=$installbuilddir],
|
|
+ [$apache_apr_flags --prefix=$prefix --exec-prefix=$exec_prefix --libdir=$libdir --includedir=$includedir --bindir=$libdir --datadir=$datadir --with-installbuilddir=$installbuilddir],
|
|
[--enable-layout=*|\'--enable-layout=*])
|
|
dnl We must be the first to build and the last to be cleaned
|
|
AP_BUILD_SRCLIB_DIRS="apr $AP_BUILD_SRCLIB_DIRS"
|
|
@@ -96,7 +96,7 @@
|
|
|
|
if test "$apu_found" = "reconfig"; then
|
|
APR_SUBDIR_CONFIG(srclib/apr-util,
|
|
- [--with-apr=../apr --prefix=$prefix --exec-prefix=$exec_prefix --libdir=$libdir --includedir=$includedir --bindir=$bindir],
|
|
+ [--with-apr=../apr --prefix=$prefix --exec-prefix=$exec_prefix --libdir=$libdir --includedir=$includedir --bindir=$libdir],
|
|
[--enable-layout=*|\'--enable-layout=*])
|
|
dnl We must be the last to build and the first to be cleaned
|
|
AP_BUILD_SRCLIB_DIRS="$AP_BUILD_SRCLIB_DIRS apr-util"
|
|
@@ -532,8 +532,12 @@
|
|
[Root directory of the Apache install area])
|
|
AC_DEFINE_UNQUOTED(SERVER_CONFIG_FILE, "${rel_sysconfdir}/${progname}.conf",
|
|
[Location of the config file, relative to the Apache root directory])
|
|
+AC_DEFINE_UNQUOTED(DEFAULT_ERRORLOG, "${rel_logfiledir}/httpd-error.log",
|
|
+ [Location of error log file])
|
|
AC_DEFINE_UNQUOTED(AP_TYPES_CONFIG_FILE, "${rel_sysconfdir}/mime.types",
|
|
[Location of the MIME types config file, relative to the Apache root directory])
|
|
+AC_DEFINE_UNQUOTED(DOCUMENT_LOCATION, "${rel_htdocsdir}",
|
|
+ [Location of document root])
|
|
AC_DEFINE_UNQUOTED(APACHE_MPM_DIR, "$MPM_DIR",
|
|
[Location of the source for the current MPM])
|
|
|