51 lines
1.4 KiB
Text
51 lines
1.4 KiB
Text
--- sys/unix/Makefile.top.orig Mon Feb 9 12:12:22 2004
|
|
+++ sys/unix/Makefile.top Mon Feb 9 12:13:05 2004
|
|
@@ -14,18 +14,17 @@
|
|
# MAKE = make
|
|
|
|
# make NetHack
|
|
-PREFIX = /usr
|
|
-GAME = jnethack
|
|
+GAME = %%HACKNAME%%
|
|
# GAME = nethack.prg
|
|
GAMEUID = games
|
|
-GAMEGRP = bin
|
|
+GAMEGRP = games
|
|
|
|
# Permissions - some places use setgid instead of setuid, for instance
|
|
# See also the option "SECURE" in include/config.h
|
|
-GAMEPERM = 04755
|
|
-FILEPERM = 0644
|
|
+GAMEPERM = 02755
|
|
+FILEPERM = 0664
|
|
EXEPERM = 0755
|
|
-DIRPERM = 0755
|
|
+DIRPERM = 0775
|
|
|
|
# GAMEDIR also appears in config.h as "HACKDIR".
|
|
# VARDIR may also appear in unixconf.h as "VAR_PLAYGROUND" else GAMEDIR
|
|
@@ -35,12 +34,12 @@
|
|
# therefore there should not be anything in GAMEDIR that you want to keep
|
|
# (if there is, you'll have to do the installation by hand or modify the
|
|
# instructions)
|
|
-GAMEDIR = $(PREFIX)/games/lib/$(GAME)dir
|
|
+GAMEDIR = %%HACKDIR%%
|
|
VARDIR = $(GAMEDIR)
|
|
-SHELLDIR = $(PREFIX)/games
|
|
+SHELLDIR = $(PREFIX)/bin
|
|
|
|
# per discussion in Install.X11 and Install.Qt
|
|
-VARDATND =
|
|
+# VARDATND =
|
|
# VARDATND = x11tiles NetHack.ad pet_mark.xbm
|
|
# VARDATND = x11tiles NetHack.ad pet_mark.xbm rip.xpm
|
|
# for Atari/Gem
|
|
@@ -48,7 +47,7 @@
|
|
# for BeOS
|
|
# VARDATND = beostiles
|
|
# for Gnome
|
|
-# VARDATND = x11tiles pet_mark.xbm rip.xpm mapbg.xpm
|
|
+VARDATND = x11tiles pet_mark.xbm rip.xpm mapbg.xpm
|
|
|
|
VARDATD = data joracles options quest.dat jrumors
|
|
VARDAT = $(VARDATD) $(VARDATND)
|