27 lines
688 B
Text
27 lines
688 B
Text
--- ./hexenworld/Client/Makefile.orig 2008-04-03 20:37:25.000000000 -0300
|
|
+++ ./hexenworld/Client/Makefile 2008-04-21 15:15:19.000000000 -0300
|
|
@@ -115,13 +115,13 @@
|
|
USE_SDLAUDIO=yes
|
|
USE_MIDI=yes
|
|
USE_CDAUDIO=yes
|
|
-USE_SDLCD=no
|
|
+USE_SDLCD=yes
|
|
WITH_SPLASHES=yes
|
|
LINK_DIRECTX=no
|
|
OPT_EXTRA=yes
|
|
LINK_GL_LIBS=no
|
|
USE_3DFXGAMMA=yes
|
|
-USE_X86_ASM=yes
|
|
+USE_X86_ASM?=no
|
|
COMPILE_32BITS=no
|
|
|
|
# include the common dirty stuff
|
|
@@ -167,7 +167,7 @@
|
|
|
|
else
|
|
|
|
-CFLAGS := $(CPUFLAGS) -O2 -Wall -ffast-math -fexpensive-optimizations
|
|
+CFLAGS := $(CFLAGS) $(CPUFLAGS) -O2 -Wall -ffast-math -fexpensive-optimizations
|
|
|
|
ifdef NO_UNIT_AT_A_TIME
|
|
CFLAGS := $(CFLAGS) $(call check_gcc,-fno-unit-at-a-time,)
|