freebsd-ports/science/kst2/files/patch-src__kst__CMakeLists.txt
Adriaan de Groot bc2e03280a science/kst2: fix build ahead of CMake 3.20
Multiple else() blocks with one if() were treated as if they
were elseif() blocks except for the last one; this is now a
syntax error.
2021-04-07 01:02:53 +02:00

13 lines
553 B
Text

--- src/kst/CMakeLists.txt.orig 2021-01-24 05:51:19 UTC
+++ src/kst/CMakeLists.txt
@@ -38,9 +38,7 @@ kst_install_executable()
if(UNIX AND NOT APPLE)
set(man ${CMAKE_BINARY_DIR}/${kst_binary_name}.1)
configure_file(${kst_dir}/src/kst/kst.1.txt ${man})
- install(CODE "execute_process(COMMAND gzip ${man})")
- set_source_files_properties(${man}.gz PROPERTIES GENERATED TRUE)
- install(FILES ${man}.gz DESTINATION share/man/man1)
+ install(FILES ${man} DESTINATION share/man/man1)
set(k ${kst_dir}/src/kst)
# install(FILES ${k}/kstplugin.desktop