freebsd-ports/net-mgmt/net-snmp/files/patch-configure.in
Jun Kuriyama bd92a4a0a5 - Upgrade to 5.3.1 [1].
- Add $snmpd_flush_cache knob [2].
- Add conflict with net-snmp-4.* [3].

PR:	ports/97673 [1] (but mostly rewritten), ports/106036 [2],
	ports/103462 [3]
Submitted by:	Rick van der Zwet <rick@wzoeterwoude.net> [1],
	"Brian A. Seklecki"<bseklecki@collaborativefusion.com> [2],
	Mykola Dzham <freebsd@levsha.org.ua> [3]
2007-02-28 01:17:16 +00:00

38 lines
1 KiB
Text

--- configure.in.orig Fri Jul 14 06:55:27 2006
+++ configure.in Tue Feb 27 20:29:49 2007
@@ -2171,7 +2171,7 @@
# fall back
CFLAG="-f"
fi
-for i in /vmunix /hp-ux /stand/vmunix /dev/ksyms /kernel/unix /kernel/genunix /netbsd /unix /kernel /bsd /mach_kernel /boot/kernel/kernel
+for i in /vmunix /hp-ux /stand/vmunix /dev/ksyms /kernel/unix /kernel/genunix /netbsd /unix /kernel /bsd /mach_kernel /boot/kernel/kernel /dev/null
do
if test -f $i -o $CFLAG $i; then
ac_cv_KERNEL_LOC="$i"
@@ -3145,6 +3145,26 @@
# checking for 4.3 vs 4.4 rtentry.
AC_CACHE_CHECK(type of rtentry structure,ac_cv_RTENTRY_TYPE,
[
+
+dnl 4.4 compatible but renamed on FreeBSD
+AC_TRY_COMPILE([
+#include <sys/types.h>
+#define KERNEL
+#define _KERNEL
+#include <sys/socket.h>
+#undef KERNEL
+#undef _KERNEL
+#include <net/route.h>
+],[
+
+#ifndef STRUCT_RTENTRY_HAS_RT_DST
+#define rt_dst rt_nodes->rn_key
+#endif
+
+ struct rtentry rt;
+ rt.rt_nodes[0].rn_bit = 1;
+ rt.rt_dst;
+ ], ac_cv_RTENTRY_TYPE="BSD-4.4")
# 4.4 compat
AC_TRY_COMPILE([