335b7e4c69
Make some more options tunable Noted by: Jan-Peter Koopmann <Jan-Peter.Koopmann@seceidos.de>
145 lines
5.1 KiB
Text
145 lines
5.1 KiB
Text
--- src/EDITME.orig Mon Dec 1 12:15:41 2003
|
|
+++ src/EDITME Mon Jan 12 12:36:43 2004
|
|
@@ -98,7 +98,7 @@
|
|
# /usr/local/sbin. The installation script will try to create this directory,
|
|
# and any superior directories, if they do not exist.
|
|
|
|
-BIN_DIRECTORY=/usr/exim/bin
|
|
+BIN_DIRECTORY=XX_PREFIX_XX/sbin
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -114,7 +114,7 @@
|
|
# don't exist. It will also install a default runtime configuration if this
|
|
# file does not exist.
|
|
|
|
-CONFIGURE_FILE=/usr/exim/configure
|
|
+CONFIGURE_FILE=XX_PREFIX_XX/etc/exim/configure
|
|
|
|
# It is possible to specify a colon-separated list of files for CONFIGURE_FILE.
|
|
# In this case, Exim will use the first of them that exists when it is run.
|
|
@@ -132,7 +132,7 @@
|
|
# owner of a local mailbox.) Specifying these values as root is very strongly
|
|
# discouraged.
|
|
|
|
-EXIM_USER=
|
|
+EXIM_USER=ref:XX_EXIM_USER_XX
|
|
|
|
# If you specify EXIM_USER as a name, this is looked up at build time, and the
|
|
# uid number is built into the binary. However, you can specify that this
|
|
@@ -153,7 +153,7 @@
|
|
# for EXIM_USER (e.g. EXIM_USER=exim), you don't need to set EXIM_GROUP unless
|
|
# you want to use a group other than the default group for the given user.
|
|
|
|
-# EXIM_GROUP=
|
|
+EXIM_GROUP=XX_EXIM_GROUP_XX
|
|
|
|
# Many sites define a user called "exim", with an appropriate default group,
|
|
# and use
|
|
@@ -286,6 +286,7 @@
|
|
# LDAP_LIB_TYPE=OPENLDAP2
|
|
# LDAP_LIB_TYPE=NETSCAPE
|
|
# LDAP_LIB_TYPE=SOLARIS
|
|
+LDAP_LIB_TYPE=XX_LDAP_TYPE_XX
|
|
|
|
# If you don't set any of these, Exim assumes the original University of
|
|
# Michigan (OpenLDAP 1) library.
|
|
@@ -299,8 +300,10 @@
|
|
# specified in INCLUDE. The settings below are just examples; -lpq is for
|
|
# PostgreSQL, -lgds is for Interbase.
|
|
|
|
-# LOOKUP_INCLUDE=-I /usr/local/ldap/include -I /usr/local/mysql/include -I /usr/local/pgsql/include
|
|
-# LOOKUP_LIBS=-L/usr/local/lib -lldap -llber -lmysqlclient -lpq -lgds
|
|
+INCLUDE=-IXX_LOCALBASE_XX/include XX_DB_INCLUDES_XX
|
|
+LOOKUP_INCLUDE=XX_MYSQL_INCLUDE_XX XX_PGSQL_INCLUDE_XX XX_LDAP_INCLUDE_XX
|
|
+LOOKUP_LIBS=XX_MYSQL_LIBS_XX XX_PGSQL_LIBS_XX XX_LDAP_LIBS_XX
|
|
+DBMLIB=XX_DB_LIBS_XX
|
|
|
|
#------------------------------------------------------------------------------
|
|
# Compiling the Exim monitor: If you want to compile the Exim monitor, a
|
|
@@ -310,7 +313,7 @@
|
|
# files are defaulted in the OS/Makefile-Default file, but can be overridden in
|
|
# local OS-specific make files.
|
|
|
|
-EXIM_MONITOR=eximon.bin
|
|
+# EXIM_MONITOR=eximon.bin
|
|
|
|
|
|
|
|
@@ -373,6 +376,7 @@
|
|
|
|
# ALT_CONFIG_PREFIX=/some/directory/
|
|
# ALT_CONFIG_PREFIX=/some/directory/exim.conf-
|
|
+ALT_CONFIG_PREFIX=XX_PREFIX_XX/etc/exim/
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -417,7 +421,7 @@
|
|
# one that is set in the headers_charset option. The default setting is
|
|
# defined by this setting:
|
|
|
|
-HEADERS_CHARSET="ISO-8859-1"
|
|
+HEADERS_CHARSET="XX_DEFAULT_CHARSET_XX"
|
|
|
|
# If you are going to make use of $header_xxx expansions in your configuration
|
|
# file, or if your users are going to use them in filter files, and the normal
|
|
@@ -489,7 +493,7 @@
|
|
# SUPPORT_TLS=yes
|
|
|
|
# Uncomment this setting if you are using OpenSSL
|
|
-# TLS_LIBS=-lssl -lcrypto
|
|
+TLS_LIBS=-lssl -lcrypto
|
|
|
|
# Uncomment these settings if you are using GnuTLS
|
|
# USE_GNUTLS=yes
|
|
@@ -540,7 +544,7 @@
|
|
# Once you have done this, "make install" will build the info files and
|
|
# install them in the directory you have defined.
|
|
|
|
-# INFO_DIRECTORY=/usr/share/info
|
|
+INFO_DIRECTORY=XX_PREFIX_XX/info
|
|
|
|
|
|
#------------------------------------------------------------------------------
|
|
@@ -553,7 +557,7 @@
|
|
# %s. This will be replaced by one of the strings "main", "panic", or "reject"
|
|
# to form the final file names. Some installations may want something like this:
|
|
|
|
-# LOG_FILE_PATH=/var/log/exim_%slog
|
|
+LOG_FILE_PATH=XX_LOG_FILE_PATH_XX
|
|
|
|
# which results in files with names /var/log/exim_mainlog, etc. The directory
|
|
# in which the log files are placed must exist; Exim does not try to create
|
|
@@ -690,12 +694,20 @@
|
|
#
|
|
# USE_TCP_WRAPPERS=yes
|
|
-# CFLAGS=-O -I/usr/local/include
|
|
-# EXTRALIBS_EXIM=-L/usr/local/lib -lwrap
|
|
-#
|
|
+CFLAGS=XX_CFLAGS_XX XX_SPF_FLAGS_XX XX_SRS_FLAGS_XX
|
|
+EXTRALIBS=XX_TCP_WRAPPERS_LIBS_XX XX_PAM_LIBS_XX XX_ICONV_LIBS_XX XX_SPF_LIBS_XX XX_SRS_LIBS_XX XX_RADIUS_LIBS_XX
|
|
+
|
|
# but of course there may need to be other things in CFLAGS and EXTRALIBS_EXIM
|
|
# as well.
|
|
|
|
|
|
+# IPv6 is coming. Exim has experimental support that has been tried out on
|
|
+# one or two OS. See the file README.IPV6 for the current status of this
|
|
+# support. Do not set this option unless you are working on IPv6 and know
|
|
+# what you are doing.
|
|
+
|
|
+# HAVE_IPV6=YES
|
|
+
|
|
+
|
|
#------------------------------------------------------------------------------
|
|
# The default action of the exim_install script (which is run by "make
|
|
# install") is to install the Exim binary with a unique name such as
|
|
@@ -937,7 +939,7 @@
|
|
# (process id) to a file so that it can easily be identified. The path of the
|
|
# file can be specified here. Some installations may want something like this:
|
|
|
|
-# PID_FILE_PATH=/var/lock/exim.pid
|
|
+PID_FILE_PATH=/var/run/exim.pid
|
|
|
|
# If PID_FILE_PATH is not defined, Exim writes a file in its spool directory
|
|
# using the name "exim-daemon.pid".
|