freebsd-ports/mail/qmail/files/patch-qmail-local.c
Mario Sergio Fujikawa Ferreira 7324117abc 1) PORTREVISION bump due to [3] and [4]
2) distinfo - update checksum for outgoingip.patch: no major change
   in code
3) New patch files/patch-qmail-local.c
	-  Erik Sjlund pointed out a bug in qmail-local at
	http://www.ornl.gov/its/archives/mailing-lists/qmail/2000/10/msg00696.html
	- Precedence bug corrected by adding parentheses which
	affects .qmail files parsing code
4) Add qmail's sendmail emulation fix: "David Phillips noticed that
   sendmail's '-f' option sets a default From: header, and so should
   qmail's emulation."
	- Add distinfo checksum for the patch

Submitted by:	too many [2]
Obtained from:	http://www.qmail.org/ [3] [4]
2003-12-10 21:40:13 +00:00

11 lines
362 B
C

--- qmail-local.c.orig Sun Nov 23 18:30:43 2003
+++ qmail-local.c Sun Nov 23 18:31:31 2003
@@ -645,7 +645,7 @@
{
cmds.s[j] = 0;
k = j;
- while ((k > i) && (cmds.s[k - 1] == ' ') || (cmds.s[k - 1] == '\t'))
+ while ((k > i) && ((cmds.s[k - 1] == ' ') || (cmds.s[k - 1] == '\t')))
cmds.s[--k] = 0;
switch(cmds.s[i])
{