freebsd-ports/devel/sfml/files/patch-src-SFML-Network-Makefile
Dmitry Marakasov cfc73e2aca SFML is a portable and easy to use multimedia API written in C++.
You can see it as a modern, object-oriented alternative to SDL.

SFML is composed of several packages to perfectly suit your needs.
You can use SFML as a minimal windowing system to interface with
OpenGL, or as a fully-featured multimedia library for building games
or interactive programs.

WWW: http://www.sfml-dev.org/index.php
2009-07-16 14:56:33 +00:00

15 lines
492 B
Text

--- src/SFML/Network/Makefile.orig 2009-05-28 19:57:08.000000000 +0400
+++ src/SFML/Network/Makefile 2009-07-07 20:01:13.000000000 +0400
@@ -17,10 +17,10 @@
$(AR) $(ARFLAGS) $(LIBNAME) $(OBJ)
libsfml-network.so: $(OBJ)
- $(CPP) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ)
+ $(CXX) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ)
$(OBJ): %.o: %.cpp
- $(CPP) -o $@ -c $< $(CFLAGS)
+ $(CXX) -o $@ -c $< $(CXXFLAGS)
.PHONY: clean mrproper