freebsd-ports/security/pks/files/patch-kd_generic.c
Matthias Andree b50a4b0708 Berkeley DB cleanup, remove versions 4.0 ... 4.7.
- Mk/bsd.database.mk rewrite, new default to db5.
- db6 is eligible by default only if installed on the system.
- Bump PORTREVISION of all ports that directly depend on BerkeleyDB or
  where USE_BDB is found in the port's directory
- Patch a few ports such that they will pick up or work with newer
  versions.
- Add UPDATING entry
- Drive-by format fix for pks
- Drop BerkeleyDB option from mail/popular for now, requires more work.
- Exp-run logs linked from the PR below.
- Ports that do not build (IGNORE, BROKEN, etc.) have pro-forma changes
  for new Berkeley DB, but are untested.

NOTE: please read UPDATING and the Wiki page before proceeding!

Announcement:	http://lists.freebsd.org/pipermail/freebsd-ports-announce/2014-August/000090.html
Wiki reference:	https://wiki.freebsd.org/Ports/BerkeleyDBCleanup
PR:		192690
Approved by:	portmgr (implicit, PORTREVISION bump on unstaged ports)
2014-08-21 22:50:29 +00:00

26 lines
916 B
C

--- ./kd_generic.c.orig 2003-08-04 21:57:27.000000000 +0200
+++ ./kd_generic.c 2014-08-15 18:41:14.000000000 +0200
@@ -325,13 +325,13 @@
/* create/open/close/sync */
static int
-kd_worddata_compare (DB * db, const DBT * a, const DBT * b)
+kd_worddata_compare (DB * db, const DBT * a, const DBT * b, size_t *locp)
{
return (memcmp (b->data, a->data, 12));
}
static void
-kd_errcall (const char *db_errpfx, char *buffer)
+kd_errcall (const DB_ENV *dbenv, const char *db_errpfx, const char *buffer)
{
log_error (db_errpfx ? db_errpfx : "db_errcall", buffer);
}
@@ -396,7 +396,6 @@
if (oflags & KD_OPEN_RECOVER)
{
appflags |= DB_INIT_LOG | DB_RECOVER | DB_CREATE;
- dbenv->set_verbose (dbenv, DB_VERB_CHKPOINT, 1);
dbenv->set_verbose (dbenv, DB_VERB_WAITSFOR, 1);
dbenv->set_verbose (dbenv, DB_VERB_DEADLOCK, 1);
dbenv->set_verbose (dbenv, DB_VERB_RECOVERY, 1);