freebsd-ports/java/berkeley-db/files/patch-junit
Mikhail Teterin 2d147a6000 Upgrade from 1.7.1 to 3.1.0, thanks largely to the diffs supplied by ijliao
(for the earlier version 3.0.12).

Make post-build test possible (via OPTIONS) and, unfortunately, disable it
by default due to several test failures. (Java-maintainers may want to take
a look.)

Switch to an auto-generated pkg-plist (HUGE amount of examples and
documentation).

Ying-Chieh is planning to delete his databases/java-db and is invited to
take over this port.
2006-10-07 01:40:24 +00:00

32 lines
1 KiB
Text

--- build.xml Wed Sep 20 18:10:10 2006
+++ build.xml Fri Oct 6 20:12:12 2006
@@ -80,7 +80,9 @@
</path>
+ <property environment="env"/>
<path id="unittest.classpath">
<pathelement location="${destdir}"/>
<pathelement location="."/>
+ <pathelement location="${env.JAVALIBDIR}/junit.jar"/>
<pathelement location="${unittest.destdir}"/>
</path>
@@ -469,4 +471,5 @@
<property name="destdir" value="${unittest.testevolvedir}"/>
<reference refid="class.path" torefid="compile.classpath"/>
+ <reference refid="unittest.classpath" torefid="compile.classpath"/>
</ant>
</target>
@@ -1224,5 +1227,4 @@
<mkdir dir="${installdir}"/>
<mkdir dir="${installdir}/docs"/>
- <mkdir dir="${installdir}/bin"/>
<mkdir dir="${installdir}/lib"/>
<copy todir="${installdir}/docs">
@@ -1233,7 +1235,4 @@
<copy todir="${installdir}/lib">
<fileset dir="lib"/>
- </copy>
- <copy todir="${installdir}/bin">
- <fileset dir="bin"/>
</copy>
</target>