and chase base GCC changes (Objective-C no longer build in 9+, uses port), and make a few other changes, to fix the build. [1] While here: - support staging - strip installed .so file unless under WITH_DEBUG regime - convert NOPORTEXAMPLES to optionsNG, too PR: ports/175692 Submitted by: snb@ (maintainer) [1]
11 lines
451 B
Text
11 lines
451 B
Text
--- tests/Makefile.in.orig 2006-08-01 05:51:52.000000000 +0200
|
|
+++ tests/Makefile.in 2013-06-09 06:33:07.000000000 +0200
|
|
@@ -26,7 +26,7 @@
|
|
CFLAGS+= @CHECK_CFLAGS@ -DTEST_DATA=\"${srcdir}/data\"
|
|
OBJCFLAGS+= @CHECK_CFLAGS@ -DTEST_DATA=\"${srcdir}/data\"
|
|
LIBS+= -lauth-ldap-testing $(OBJC_LIBS) $(LDAP_LIBS) @CHECK_LIBS@
|
|
-LDFLAGS+= -L${top_builddir}src $(LIBS)
|
|
+LDFLAGS+= -L${top_builddir}/src $(LIBS)
|
|
|
|
# Recompile the tests every time
|
|
all: tests
|