freebsd-ports/misc/sssnips/files/patch-Makefile
Danilo Egea Gondolfo f52c92b1c0 - Update from 0.04 to 0.05
- Convert USE_GMAKE to USES
- Add stage support

while here
- Add a patch to install the files as user (remove -o and -g parameters from install)

PR:		ports/185700
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
2014-01-18 02:49:02 +00:00

15 lines
590 B
Text

--- ./Makefile.orig 2014-01-18 00:23:54.000000000 -0200
+++ ./Makefile 2014-01-18 00:24:44.000000000 -0200
@@ -72,9 +72,9 @@
COPY?= -c
STRIP?= -s
-INSTALL_PROGRAM?= ${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE}
-INSTALL_SCRIPT?= ${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE}
-INSTALL_DATA?= ${INSTALL} ${COPY} -o ${SHAREOWN} -g ${SHAREGRP} -m ${SHAREMODE}
+INSTALL_PROGRAM?= ${INSTALL} ${COPY} ${STRIP} -m ${BINMODE}
+INSTALL_SCRIPT?= ${INSTALL} ${COPY} -m ${BINMODE}
+INSTALL_DATA?= ${INSTALL} ${COPY} -m ${SHAREMODE}
all: ${SCRIPTS} ${MAN1}