freebsd-ports/editors/openoffice-3/files/debugpatch-solenv+inc+unxfbsdi.mk
Maho Nakata e319abfdca Fix debug patches, which were not correctly applied.
Submitted by:	Hiromi Kimura <hiromi@tac.tsukuba.ac.jp>
2003-04-28 07:09:58 +00:00

18 lines
553 B
Makefile

--- ../solenv/inc/unxfbsdi.mk.orig Mon Jul 22 00:40:56 2002
+++ ../solenv/inc/unxfbsdi.mk Mon Jul 22 00:42:02 2002
@@ -92,12 +92,12 @@
CDEFS+= $(PTHREAD_CFLAGS) -D_REENTRANT
# flags for C and C++ Compile
-CFLAGS+= -w -c $(INCLUDE)
+CFLAGS+= -g -ggdb -w -c $(INCLUDE)
CFLAGS+= -I/usr/X11R6/include
# flags for the C++ Compiler
-CFLAGSCC= -pipe
-CFLAGSCXX= -pipe -fno-for-scope -fpermissive
+CFLAGSCC= -g -ggdb -pipe
+CFLAGSCXX= -g -ggdb -pipe -fno-for-scope -fpermissive
# Flags for enabling exception handling
CFLAGSEXCEPTIONS= -fexceptions