35 lines
1.1 KiB
Text
35 lines
1.1 KiB
Text
--- configure.in.orig Tue Jun 6 00:42:49 2000
|
|
+++ configure.in Sat Jul 1 20:46:31 2000
|
|
@@ -147,6 +150,15 @@
|
|
machine='' opsys='' unported=no
|
|
case "${canonical}" in
|
|
|
|
+ ## FreeBSD ports
|
|
+ *-*-freebsd* )
|
|
+ opsys=freebsd
|
|
+ case "${canonical}" in
|
|
+ alpha*-*-freebsd*) machine=alpha ;;
|
|
+ i[3456]86-*-freebsd*) machine=intel386 ;;
|
|
+ esac
|
|
+ ;;
|
|
+
|
|
## NetBSD ports
|
|
*-*-netbsd* )
|
|
opsys=netbsd
|
|
@@ -958,7 +970,6 @@
|
|
;;
|
|
*-sysv4.2uw* ) opsys=unixware; NON_GNU_CPP=/lib/cpp ;;
|
|
*-386bsd* ) opsys=386bsd ;;
|
|
- *-freebsd* ) opsys=freebsd ;;
|
|
*-nextstep* ) opsys=nextstep ;;
|
|
## Otherwise, we'll fall through to the generic opsys code at the bottom.
|
|
esac
|
|
@@ -1639,7 +1650,7 @@
|
|
rename closedir mkdir rmdir sysinfo \
|
|
random lrand48 bcopy bcmp logb frexp fmod rint cbrt ftime res_init setsid \
|
|
strerror fpathconf select mktime euidaccess getpagesize tzset setlocale \
|
|
-utimes setrlimit setpgid getcwd shutdown strftime)
|
|
+utimes setrlimit setpgid getcwd shutdown strftime getaddrinfo)
|
|
|
|
# UNIX98 PTYs.
|
|
AC_CHECK_FUNCS(grantpt)
|