freebsd-ports/comms/smstools3/files/patch-src-Makefile
2017-02-23 14:25:24 +00:00

38 lines
1.1 KiB
Text

--- src/Makefile.orig 2017-02-08 20:40:28 UTC
+++ src/Makefile
@@ -1,7 +1,7 @@
# In case of windows, use os_cygwin=yes setting in the configuration file (smsd.conf).
# Select your setup size:
-CFLAGS = -D NUMBER_OF_MODEMS=64
+CFLAGS += -DNUMBER_OF_MODEMS=64
# Uncomment for Solaris
# CFLAGS += -D SOLARIS
@@ -9,7 +9,7 @@ CFLAGS = -D NUMBER_OF_MODEMS=64
# CC=gcc
# Comment this out, to enable statistics
-CFLAGS += -D NOSTATS
+#CFLAGS += -D NOSTATS
# Uncomment this to force smsd to run in terminal mode
#CFLAGS += -D TERMINAL
@@ -46,14 +46,14 @@ smsd: smsd.c extras.o locking.o cfgfile.
ifneq (,$(findstring SOLARIS,$(CFLAGS)))
ifeq (,$(findstring DISABLE_INET_SOCKET,$(CFLAGS)))
- override LFLAGS += -lsocket -lnsl
+ override LDFLAGS += -lsocket -lnsl
endif
endif
ifneq (,$(findstring NOSTATS,$(CFLAGS)))
- $(CC) $(CFLAGS) -o $@ $^ $(LFLAGS)
+ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
else
- $(CC) `mm-config --cflags` $(CFLAGS) -o $@ $^ `mm-config --ldflags --libs` $(LFLAGS)
+ $(CC) `mm-config --cflags` $(CFLAGS) -o $@ $^ `mm-config --ldflags --libs` $(LDFLAGS)
endif
clean: