c5093c3118
Changes in software: - vendor's bugfixes - new FLUTE support - new dependencies in gdome-2 and glib20 - properly install the shared library and headers - replace -pthread with $PTHREAD_LIBS - fix compilation warnings due to C++ headers in -current PR: ports/61068 Submitted by: Panagiotis Astithas <past@noc.ntua.gr> (maintainer)
17 lines
377 B
Text
17 lines
377 B
Text
--- mclftp/Makefile.orig Wed Dec 17 00:13:34 2003
|
|
+++ mclftp/Makefile Wed Dec 17 00:15:56 2003
|
|
@@ -36,6 +36,14 @@
|
|
LIBRARIES = -lc -lm -lsocket -lnsl /usr/ucblib/libucb.a -lposix4 -lpthread
|
|
endif
|
|
|
|
+ifeq (${OS},freebsd)
|
|
+ # FreeBSD version
|
|
+ # MCL library requires -pthread
|
|
+ #
|
|
+ BINDIR = ../bin/freebsd
|
|
+ LIBRARIES = -lm -pthread
|
|
+endif
|
|
+
|
|
|
|
|
|
###### Other variables ######
|