freebsd-ports/deskutils/kdepim44-runtime/files/patch-resources__kolabproxy__CMakeLists.txt
Max Brazhnikov 1f8475f22f Mk/bsd.kde4.mk:
- rework KDE4_BUILDENV

All ports:
- remove needless post-extract target
- make patches relative to ${PATCH_WRKSRC}
- clean up
- bump PORTREVISION when required

databases/akonadi:
- replace dependency on boost-python-libs with boost-libs
  (finally, boost-pyhton does not conflict with boost \o/)

deskutils/kdepim*:
- replace boost-python-libs with boost-libs
- reduce dependencies
- respect PREFIX
- fix build with qt3 installed

misc/kdeedu4:
- add dependency on astro/xplanet (for KStars)

misc/kdeutils4:
- add dependency on devel/qca (for okteta)
- make dependency on kdebase non-optional

multimedia/kdemultimedia4:
- add optional support for PulseAudio

x11/kdebase4:
- remove needless dependency on kdebase4-runtime

x11/kdebase4-runtime, x11/kdebase4-workspace
- remove extra CMAKE_ARGS to fix build for qt3/kde3 users

x11/kdelibs4
- remove needless dependencies
- remove extra CMAKE_ARGS to fix build for qt3/kde3 users
2009-08-10 11:47:36 +00:00

14 lines
411 B
Text

--- ./resources/kolabproxy/CMakeLists.txt.orig 2009-08-04 09:09:41.000000000 +1100
+++ ./resources/kolabproxy/CMakeLists.txt 2009-08-10 19:40:23.000000000 +1100
@@ -1,8 +1,10 @@
project(kolabproxy)
include_directories(
- ${kdepim-runtime_SOURCE_DIR}
+ ${QT_QTCORE_INCLUDE_DIR}
+ ${QT_QTGUI_INCLUDE_DIR}
${QT_QTDBUS_INCLUDE_DIR}
+ ${kdepim-runtime_SOURCE_DIR}
${Boost_INCLUDE_DIR}
)