structure (i.e. include/SDL for includes and sdl-config for configuration binary) - Update graphics/sdl_ttf to version 2.0.8 - Update graphics/sdl_image to version 1.2.5 - Update audio/sdl_mixer to version 1.2.7 - Update net/sdl_net to version 1.2.6 - Update Mk/bsd.sdl.mk accordingly - Fix dependent ports to fit the new directory structure and avoid several API breakages - Bump up portrevisions for all dependent ports to allow them to be upgraded by portupgrade/portmaster etc tools Approved by: kris (portmgr), sem (mentor)
99 lines
3.8 KiB
Text
99 lines
3.8 KiB
Text
--- makefile.orig Sun Apr 18 18:02:24 2004
|
|
+++ makefile Mon Sep 19 20:44:29 2005
|
|
@@ -260,12 +260,10 @@
|
|
|
|
# gcc or g++
|
|
#CC=@gcc
|
|
-CC=gcc
|
|
|
|
#if use PGCC or EGCS
|
|
PGCC=1
|
|
|
|
-WFLAGS=-Wall # -W -Wno-unused -Wno-sign-compare
|
|
|
|
#uncomment if you want to use the POLL_POINTER hack
|
|
#POLL_POINTER=-DPOLL_POINTER
|
|
@@ -407,7 +405,8 @@
|
|
|
|
OPTS := $(OPTS) -DVID_X11 $(POLL_POINTER) -I. -I/usr/X11R6/include
|
|
LDFLAGS=-L/usr/X11R6/lib
|
|
- LIBS=-lXext -lX11 -lm -lXxf86vm -lipx -lkvm -pthread
|
|
+ LIBS=-lXext -lX11 -lm -lXxf86vm -lipx -lkvm ${PTHREAD_LIBS}
|
|
+ CFLAGS+=${PTHREAD_CFLAGS}
|
|
# name of the exefile
|
|
EXENAME=llxdoom
|
|
SFLAGS=-g $(OPTS)
|
|
@@ -418,7 +417,7 @@
|
|
else #ifdef X
|
|
ifdef FBSD_SDL
|
|
INTERFACE=sdl
|
|
- OPTS := -DLINUX -DFREEBSD -DHWRENDER -DDIRECTFULLSCREEN -DHAVE_MIXER -DSDL -DVID_X11 $(POLL_POINTER) -I. -I/usr/local/include/SDL11 -I/usr/X11R6/include -Wall
|
|
+ OPTS := -DLINUX -DFREEBSD -DHWRENDER -DDIRECTFULLSCREEN -DHAVE_MIXER -DSDL -DVID_X11 $(POLL_POINTER) -I. -I/usr/local/include/SDL -I/usr/local/include -I/usr/X11R6/include
|
|
SFLAGS=-g $(OPTS)
|
|
OBJS=$(O)/i_video.o $(O)/dosstr.o $(O)/endtxt.o \
|
|
$(O)/hw_bsp.o $(O)/hw_draw.o $(O)/hw_light.o $(O)/hw_main.o \
|
|
@@ -428,7 +427,8 @@
|
|
DEBUGLIBS=$(LIBS)
|
|
|
|
LDFLAGS=-L/usr/X11R6/lib -L/usr/local/lib
|
|
- LIBS=-lm -lSDL-1.1 -lSDL_mixer -lGL -lGLU -lipx -lkvm -pthread
|
|
+ LIBS=-lm -lSDL -lSDL_mixer -lGL -lGLU -lipx -lkvm ${PTHREAD_LIBS}
|
|
+ CFLAGS+=${PTHREAD_CFLAGS}
|
|
DEBUGLIBS=$(LIBS)
|
|
|
|
# name of the exefile
|
|
@@ -533,11 +533,7 @@
|
|
|
|
ifndef SOLARIS
|
|
ifdef GCC30
|
|
- M5=-march=pentium
|
|
- M4=-march=486
|
|
else
|
|
- M5=-mpentium
|
|
- M4=-m486
|
|
endif
|
|
endif
|
|
|
|
@@ -555,13 +551,13 @@
|
|
|
|
# build a normal optimised version
|
|
ifdef PGCC
|
|
- CFLAGS = $(OPTS) $(M5) -O6 -ffast-math -fomit-frame-pointer -fwritable-strings
|
|
+ CFLAGS += $(OPTS)
|
|
# -fgcse -fcse-follow-jumps -fcse-skip-blocks -frerun-cse-after-loop -ffunction-cse \
|
|
# -fexpensive-optimizations -fforce-mem -fstrength-reduce -fthread-jumps \
|
|
# -fregmove -fschedule-insns -fschedule-insns2 -fmove-all-movables \
|
|
# -fcaller-saves -finline-functions -mieee-fp -mfp-ret-in-387 -m80387 -mhard-float -finline
|
|
else
|
|
- CFLAGS = $(M4) -O3 -ffast-math -fomit-frame-pointer -fwritable-strings $(OPTS)
|
|
+ CFLAGS += $(OPTS)
|
|
endif
|
|
endif
|
|
|
|
@@ -735,7 +731,7 @@
|
|
|
|
#dll
|
|
dll : $(O)/r_opengl.o $(O)/ogl_x11.o
|
|
- $(CC) $(M5) -O6 -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
|
|
+ $(CC) $(CFLAGS) -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
|
|
|
|
musserv:
|
|
@mkdir -p $(MUSSERV)/linux
|
|
@@ -760,7 +756,7 @@
|
|
ifdef FREEBSD
|
|
ifdef FBSD_SDL
|
|
$(O)/r_opengl.o: hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
|
|
- $(CC) $(CFLAGS) $(LDFLAGS) $(WFLAGS) -I/usr/X11R6/include -c $< -o $@
|
|
+ $(CC) -fPIC $(CFLAGS) $(LDFLAGS) $(WFLAGS) -I/usr/X11R6/include -c $< -o $@
|
|
else #FBSD_SDL
|
|
$(O)/r_opengl.o: hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
|
|
$(CC) $(M5) -O6 -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
|
|
@@ -777,7 +773,7 @@
|
|
$(CC) $(M5) -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
|
|
else
|
|
$(O)/ogl_x11.o: hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
|
|
- $(CC) $(M5) -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
|
|
+ $(CC) -fPIC $(CFLAGS) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
|
|
endif
|
|
|
|
|