d765c72be9
- Unify ICU handling PR: ports/153245 Approved by: maintainer (timeout)
38 lines
1.4 KiB
Text
38 lines
1.4 KiB
Text
--- configure.in.orig 2010-12-17 10:28:46.362381801 +0100
|
|
+++ configure.in 2010-12-17 10:31:27.692004326 +0100
|
|
@@ -945,15 +945,27 @@
|
|
fi
|
|
|
|
if test "$with_icu" = yes ; then
|
|
- AC_CHECK_LIB(icui18n, ucol_open_3_8, [], [
|
|
- AC_CHECK_LIB(icui18n, ucol_open_3_6, [], [
|
|
- AC_CHECK_LIB(icui18n, ucol_open_3_4, [], [AC_MSG_ERROR([library 'icui18n' is required for ICU])])
|
|
- ])
|
|
+ AC_CHECK_LIB(icui18n, ucol_open_46, [], [
|
|
+ AC_CHECK_LIB(icui18n, ucol_open_44, [], [
|
|
+ AC_CHECK_LIB(icui18n, ucol_open_43, [], [
|
|
+ AC_CHECK_LIB(icui18n, ucol_open_3_8, [], [
|
|
+ AC_CHECK_LIB(icui18n, ucol_open_3_6, [], [
|
|
+ AC_CHECK_LIB(icui18n, ucol_open_3_4, [], [AC_MSG_ERROR([library 'icui18n' is required for ICU])])
|
|
+ ])
|
|
+ ])
|
|
+ ])
|
|
+ ])
|
|
])
|
|
- AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_8, [], [
|
|
- AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_6, [], [
|
|
- AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_4, [], [AC_MSG_ERROR([library 'icuuc' is required for ICU])])
|
|
- ])
|
|
+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_46, [], [
|
|
+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_44, [], [
|
|
+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_43, [], [
|
|
+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_8, [], [
|
|
+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_6, [], [
|
|
+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_4, [], [AC_MSG_ERROR([library 'icuuc' is required for ICU])])
|
|
+ ])
|
|
+ ])
|
|
+ ])
|
|
+ ])
|
|
])
|
|
fi
|
|
|