freebsd-ports/news/husky/files/patch-hpt_Makefile
John Marino a42ec116be Remove '-devel' prefix from husky* ports
Today the older unstaged husky-* ports were removed as the first part
of a transition move the development versions into their place.  This
commit completes the relocation of husky-*-devel ports.
2014-08-19 22:10:13 +00:00

23 lines
614 B
Text

--- hpt/Makefile.orig 2010-01-19 22:43:29.000000000 +0000
+++ hpt/Makefile 2013-04-13 19:28:49.000000000 +0000
@@ -33,6 +33,7 @@ endif
ifeq ($(PERL), 1)
CFLAGS += -DDO_PERL `perl -MExtUtils::Embed -e ccopts`
PERLLIBS = `perl -MExtUtils::Embed -e ldopts`
+ LFLAGS += $(PERLLIBS)
PERLOBJ = perl$(_OBJ)
endif
@@ -61,10 +62,10 @@ all: commonall hpt.1.gz hptlink.1.gz hpt
endif
doc:
- -cd doc; make all
+ -cd doc; $(MAKE) all
install-doc:
- -cd doc; make install
+ -cd doc; $(MAKE) install
ifeq ($(SHORTNAMES), 1)
install: hpt$(_EXE) pktinfo$(_EXE) txt2pkt$(_EXE) hptlink$(_EXE) hpttree$(_EXE)