freebsd-ports/news/husky/files/patch-smapi_Makefile
John Marino a42ec116be Remove '-devel' prefix from husky* ports
Today the older unstaged husky-* ports were removed as the first part
of a transition move the development versions into their place.  This
commit completes the relocation of husky-*-devel ports.
2014-08-19 22:10:13 +00:00

50 lines
1.9 KiB
Text

--- smapi/Makefile.orig 2013-03-24 23:40:00.000000000 +0000
+++ smapi/Makefile 2013-03-24 23:40:05.000000000 +0000
@@ -33,7 +33,7 @@ CDEFS=-D$(OSTYPE) $(ADDCDEFS) -I$(H_DIR)
LIBS=-lhusky
ifeq ($(DYNLIBS), 1)
-all: $(TARGETLIB) $(TARGETDLL).$(VER)
+all: $(TARGETLIB) $(TARGETDLL).$(VERMAJOR)
else
all: $(TARGETLIB)
endif
@@ -50,24 +50,22 @@ endif
ifeq ($(DYNLIBS), 1)
ifeq (~$(MKSHARED)~,~ld~)
-$(TARGETDLL).$(VER): $(OBJS)
- $(LD) $(LFLAGS) -o $(TARGETDLL).$(VER) $(OBJS) -L$(LIBDIR) $(LIBS)
+$(TARGETDLL).$(VERMAJOR): $(OBJS)
+ $(LD) $(LFLAGS) -o $(TARGETDLL).$(VERMAJOR) $(OBJS) -L$(LIBDIR) $(LIBS)
else
-$(TARGETDLL).$(VER): $(OBJS)
- $(CC) -shared -Wl,-soname,$(TARGETDLL).$(VERH) \
- -o $(TARGETDLL).$(VER) $(OBJS) -L$(LIBDIR) $(LIBS)
+$(TARGETDLL).$(VERMAJOR): $(OBJS)
+ $(CC) -shared -Wl,-soname,$(TARGETDLL).$(VERMAJOR) \
+ -o $(TARGETDLL).$(VERMAJOR) $(OBJS) -L$(LIBDIR) $(LIBS)
endif
-instdyn: $(TARGETLIB) $(TARGETDLL).$(VER)
+instdyn: $(TARGETLIB) $(TARGETDLL).$(VERMAJOR)
-$(MKDIR) $(MKDIROPT) $(DESTDIR)$(DIRSEP)$(LIBDIR)
- $(INSTALL) $(ILOPT) $(TARGETDLL).$(VER) $(DESTDIR)$(DIRSEP)$(LIBDIR)
- -$(RM) $(RMOPT) $(DESTDIR)$(DIRSEP)$(LIBDIR)$(DIRSEP)$(TARGETDLL).$(VERH)
+ $(INSTALL) $(ILOPT) $(TARGETDLL).$(VERMAJOR) $(DESTDIR)$(DIRSEP)$(LIBDIR)
-$(RM) $(RMOPT) $(DESTDIR)$(DIRSEP)$(LIBDIR)$(DIRSEP)$(TARGETDLL)
# Changed the symlinks from symlinks with full path to just symlinks.
# Better so :)
cd $(DESTDIR)$(DIRSEP)$(LIBDIR) ;\
- $(LN) $(LNOPT) $(TARGETDLL).$(VER) $(TARGETDLL).$(VERH) ;\
- $(LN) $(LNOPT) $(TARGETDLL).$(VER) $(TARGETDLL)
+ $(LN) $(LNOPT) $(TARGETDLL).$(VERMAJOR) $(TARGETDLL)
ifneq (~$(LDCONFIG)~, ~~)
$(LDCONFIG)
endif
@@ -102,4 +100,4 @@ clean:
distclean: clean
-$(RM) $(RMOPT) $(TARGETLIB)
- -$(RM) $(RMOPT) $(TARGETDLL).$(VER)
+ -$(RM) $(RMOPT) $(TARGETDLL).$(VERMAJOR)