freebsd-ports/graphics/pvmpov/files/patch-ab
Michael Johnson d85be14663 - Update to 3.1g.2
- Remove pkg-plist for use of PLIST_FILES and PORTDOCS

PR:		ports/77947
Submitted by:	Sam Lawrance <boris@brooknet.com.au>
2005-03-02 07:37:09 +00:00

51 lines
1.6 KiB
Text

--- povray31/source/pvm/Makefile.aimk.orig Sat Sep 8 00:29:33 2001
+++ povray31/source/pvm/Makefile.aimk Wed Feb 23 01:28:26 2005
@@ -45,18 +45,18 @@
# Use libXXX.a if you want to force static linking of the libraries.
# Use -Llibdir -lXXX if you want to use shared libraries (if they are
# available). It doesn't matter if you only have libXXX.a libraries.
-PNGDIR = $(SRCDIR)/libpng
-LIBPNGINC = -I$(PNGDIR)
+PNGDIR =
+LIBPNGINC = -I%LOCALBASE%/include
#LIBPNGLIB = $(PNGDIR)/libpng.a
#LIBPNGINC = -I/usr/X11R6/include
-LIBPNGLIB = -L$(PNGDIR) -lpng
+LIBPNGLIB = -L%LOCALBASE%/lib -lpng
# LIBPNGLIB = -L/usr/lib -lpng
# LIBPNGLIB = -L/usr/X11R6/lib -lpng
# LIBPNGLIB =
-ZLIBDIR = $(SRCDIR)/zlib
-ZLIBINC = -I$(ZLIBDIR)
+ZLIBDIR =
+ZLIBINC =
#ZLIBLIB = $(ZLIBDIR)/libz.a
-ZLIBLIB = -L$(ZLIBDIR) -lz
+ZLIBLIB = -lz
#ZLIBLIB = -L/usr/local/lib -lz
#
@@ -77,7 +77,7 @@
# for some AIX systems
#X11 = /usr/lpp/X11
-X11 = /usr/X11R6
+X11 = %X11BASE%
# You probably won't need to change these if you have the X11 variable
# above set properly...
@@ -115,11 +115,10 @@
CC = gcc
OBJ = .o
-PVMINC = -I$(PVM_ROOT)/include
-PVMLIB = $(PVM_ROOT)/lib/$(PVM_ARCH)/libpvm3.a \
- $(PVM_ROOT)/lib/$(PVM_ARCH)/libgpvm3.a
+PVMINC = -I%LOCALBASE%/include
+PVMLIB = -L%LOCALBASE%/lib -lpvm3 -lgpvm3
XDIR = $(HOME)/pvm3/bin/$(PVM_ARCH)
-CFLAGS = -O3 -ansi -finline-functions -ffast-math -c -Wall \
+CFLAGS = -O6 -ansi -finline-functions -ffast-math -c -Wall \
-DPVM -D$(PVM_ARCH) -DCOMPILER_VER=\".`uname`.$(CC)\" \
-DPOV_LIB_DIR=\"$(POVLIBDIR)\" \
$(SRCINC) $(LIBPNGINC) $(ZLIBINC) $(XLIBINC)