freebsd-ports/mail/thunderbird/files/patch-bug803480
Florian Smeets ec4fcd4b2a - update firefox, thunderbird and libxul to 24.0
- update seamonkey to 2.21
- update firefox-esr to 17.0.9
- enable GSTREAMER by default for html5 with h264/aac/mp3
- WEBRTC is now always built
- add PROFILE and TESTS options

Security:		7dfed67b-20aa-11e3-b8d8-0025905a4771
In collaboration with:	Jan Beich <jbeich@tormail.org>
2013-09-18 22:40:57 +00:00

102 lines
2.6 KiB
Text

diff --git configure.in configure.in
index a0575dc..be327fd 100644
--- mozilla/configure.in
+++ mozilla/configure.in
@@ -4306,7 +4306,6 @@ NS_PRINTING=1
MOZ_PDF_PRINTING=
MOZ_DISABLE_CRYPTOLEGACY=
NSS_DISABLE_DBM=
-NECKO_WIFI=1
NECKO_COOKIES=1
NECKO_PROTOCOLS_DEFAULT="about data file ftp http res viewsource websocket wyciwyg device"
USE_ARM_KUSER=
@@ -4336,11 +4335,6 @@ case "${target}" in
fi
NSS_DISABLE_DBM=1
- if test -z "$gonkdir"; then
- NECKO_WIFI=
- else
- NECKO_WIFI=1
- fi
MOZ_THEME_FASTSTRIPE=1
MOZ_TREE_FREETYPE=1
MOZ_MEMORY=1
@@ -8485,28 +8479,39 @@ done
dnl
dnl option to disable necko's wifi scanner
dnl
+
+case "$OS_TARGET" in
+ OS2)
+ dnl OS/2 implementation of Necko-WiFi support will be added in bug 506566
+ ;;
+ Android)
+ if test -n "$gonkdir"; then
+ NECKO_WIFI=1
+ fi
+ ;;
+ Darwin|SunOS|WINNT)
+ NECKO_WIFI=1
+ ;;
+ Linux)
+ if test -z "$MOZ_ENABLE_DBUS"; then
+ AC_MSG_ERROR([Necko WiFi scanning needs DBus on your platform, remove --disable-dbus or use --disable-necko-wifi])
+ fi
+ NECKO_WIFI=1
+ NECKO_WIFI_DBUS=1
+ ;;
+esac
+
MOZ_ARG_DISABLE_BOOL(necko-wifi,
[ --disable-necko-wifi Disable necko wifi scanner],
NECKO_WIFI=,
NECKO_WIFI=1)
-if test "$OS_ARCH" = "OS2"; then
- dnl OS/2 implementation of Necko-WiFi support will be added in bug 506566
- NECKO_WIFI=
-fi
-if test "$NECKO_WIFI" -a \
- "$OS_ARCH" != "Linux" -a \
- "$OS_ARCH" != "Darwin" -a \
- "$OS_ARCH" != "SunOS" -a \
- "$OS_ARCH" != "WINNT"; then
- AC_MSG_ERROR([Necko WiFi scanning not supported on your platform, use --disable-necko-wifi])
-fi
-
if test "$NECKO_WIFI"; then
AC_DEFINE(NECKO_WIFI)
_NON_GLOBAL_ACDEFINES="$_NON_GLOBAL_ACDEFINES NECKO_WIFI"
fi
AC_SUBST(NECKO_WIFI)
+AC_SUBST(NECKO_WIFI_DBUS)
dnl
dnl option to disable cookies
diff --git netwerk/wifi/Makefile.in netwerk/wifi/Makefile.in
index 26dbd79..4cbf912 100644
--- mozilla/netwerk/wifi/Makefile.in
+++ mozilla/netwerk/wifi/Makefile.in
@@ -20,7 +20,7 @@ ifeq ($(OS_ARCH),SunOS)
OS_INCLUDES += $(GLIB_CFLAGS)
endif
-ifdef MOZ_ENABLE_DBUS
+ifdef NECKO_WIFI_DBUS
OS_INCLUDES += $(MOZ_DBUS_GLIB_CFLAGS)
endif
diff --git netwerk/wifi/moz.build netwerk/wifi/moz.build
index 5e70211..07b01de 100644
--- mozilla/netwerk/wifi/moz.build
+++ mozilla/netwerk/wifi/moz.build
@@ -43,7 +43,7 @@ elif CONFIG['OS_ARCH'] == 'SunOS':
'nsWifiScannerSolaris.cpp',
]
-if CONFIG['MOZ_ENABLE_DBUS']:
+if CONFIG['NECKO_WIFI_DBUS']:
CPP_SOURCES += [
'nsWifiScannerDBus.cpp',
]