freebsd-ports/www/woadaptor/files/patch-Apache-Makefile
Edwin Groothuis e6b6e3491e [NEW PORTS] www/webobjects(+) Apple WebObjects ports bundle
This is a bundle of several ports covering many typical requirements
for building an Apple WebObjects deployment environment. Each port
is or has a dependancy with some other port in the bundle, and have
therefore been lodged collectively.

	www/woadaptor

	WOAdaptor is a collection of WebObjects WebServer Adaptors.
	These include an Apache Module, CGI and FastCGI adaptors

	This is a subproject of Project Wonder and is an effort to
	pool enhancements and bug fixes for Apple's open source
	codebase.

	WWW: http://wonder.sourceforge.net/WOAdaptor.html

PR:		ports/117299
Submitted by:	Quinton Dolan <q@onthenet.com.au>
2008-06-13 06:29:46 +00:00

33 lines
956 B
Text

--- Apache/Makefile.orig Wed Sep 18 12:57:24 2002
+++ Apache/Makefile Wed May 30 01:17:28 2007
@@ -88,5 +88,30 @@
${CC} -c ${CFLAGS} mod_WebObjects.c ${COMMON_OBJFILES}
endif
+ifeq "FreeBSD" "$(OS)"
+OPENSSLINCLUDEFLAGS =
+OPENSSLLIBFLAGS =
+
+ifdef USE_SSL
+ifdef WITH_MODSSL
+ OPENSSLINCLUDEFLAGS = -I/usr/local/include/openssl
+ OPENSSLLIBFLAGS = -L/usr/lib -lcrypto -lssl
+else
+ APXSAPACHESSLFLAG =
+endif
+endif
+
+CFLAGS += -O2 -Wall -I../Adaptor $(DEBUG_FLAG) -DSINGLE_THREADED_ADAPTOR -DFORKING_WEBSERVER -DAPACHE -fPIC `${APXS} -q CFLAGS`
+APXSFLAGS = -c -I../Adaptor ${OPENSSLLIBFLAGS} -D SINGLE_THREADED_ADAPTOR ${APXSAPACHESSLFLAG} "-I`${APXS} -q INCLUDEDIR`" -S CC=$(CC)
+
+all: mod_WebObjects.so
+
+mod_WebObjects.so : mod_WebObjects.c ${COMMON_OBJFILES}
+ ${APXS} ${APXSFLAGS} mod_WebObjects.c ${COMMON_OBJFILES}
+
+clean:
+ rm -f mod_WebObjects.so *.o
+endif
+
#################################
include ../Adaptor/make.postamble