freebsd-ports/net/asterisk12/files/patch-utils::Makefile
Maxim Sobolev 559dc94729 o Update zaptel to 1.4.1;
Submitted by:	Oleksandr Tymoshenko <gonzo@pbxpress.com>

o update libpri to 1.4.0;

PR:		111555
Submitted by:	"Phillip N." <pneumann@gmail.com>

o update asterisk12 to 1.2.7.

Sponsored by:	Sippy Software, Inc. ( http://www.sippysoft.com/ )

The reason it all is going in together is that they are interdependent.
2007-04-26 00:11:37 +00:00

32 lines
1.2 KiB
Text

--- utils/Makefile.orig Wed Jan 24 19:43:50 2007
+++ utils/Makefile Mon Apr 16 16:37:31 2007
@@ -17,17 +17,17 @@
CFLAGS+=-DNO_AST_MM
ifeq ($(findstring BSD,${OSARCH}),BSD)
- CFLAGS+=-I$(CROSS_COMPILE_TARGET)/usr/local/include -L$(CROSS_COMPILE_TARGET)/usr/local/lib
+ CFLAGS+=-I$(CROSS_COMPILE_TARGET)$(LOCALBASE)/include -L$(CROSS_COMPILE_TARGET)$(LOCALBASE)/lib
endif
# to get check_expr, add it to the TARGET list
TARGET=stereorize streamplayer
-ifneq ($(wildcard $(CROSS_COMPILE_TARGET)/usr/include/popt.h)$(wildcard -f $(CROSS_COMPILE_TARGET)/usr/local/include/popt.h),)
+ifneq ($(wildcard $(CROSS_COMPILE_TARGET)/usr/include/popt.h)$(wildcard -f $(CROSS_COMPILE_TARGET)$(LOCALBASE)/include/popt.h),)
TARGET+=smsq
endif
-ifneq ($(wildcard $(CROSS_COMPILE_TARGET)/usr/include/newt.h)$(wildcard -f $(CROSS_COMPILE_TARGET)/usr/local/include/newt.h),)
+ifneq ($(wildcard $(CROSS_COMPILE_TARGET)/usr/include/newt.h)$(wildcard -f $(CROSS_COMPILE_TARGET)$(LOCALBASE)/include/newt.h),)
TARGET+=astman
endif
@@ -41,7 +41,7 @@
install:
for x in $(TARGET); do \
if [ "$$x" != "none" ]; then \
- $(INSTALL) -m 755 $$x $(DESTDIR)$(ASTSBINDIR)/$$x; \
+ $(BSD_INSTALL_PROGRAM) $$x $(DESTDIR)$(ASTSBINDIR)/$$x; \
fi; \
done