freebsd-ports/games/quake2forge/files/patch-configure.in
Edwin Groothuis e81f50450d [UPDATE] games/quake2forge: integrate with "quake2-data"
Changes:
	* Integrate with "quake2-data".
	* Add OPTIONS.
	* Add support for Rogue and Xatrix mission packs.

PR:		ports/87180
Submitted by:	Alejandro Pulver <alejandro@varnet.biz>
2005-11-22 05:15:42 +00:00

45 lines
1.3 KiB
Text

--- configure.in.orig Tue Mar 16 07:07:38 2004
+++ configure.in Wed Sep 28 20:52:44 2005
@@ -109,6 +109,7 @@
# test for the library first, for people who may have the libs
# installed but no headers
AC_CHECK_LIB(vga, vga_getmousetype,
+ SVGALIB_LIBS="$SVGALIB_LIBS -lvga"
HAVE_SVGALIB=maybe,
HAVE_SVGALIB=no,
[ $SVGALIB_LIBS ]
@@ -125,7 +126,6 @@
# if it's all there, define the relevant bits
if test "x$HAVE_SVGALIB" = xyes ; then
AC_DEFINE(HAVE_SVGALIB, 1, [Define this if you have SVGAlib])
- SVGALIB_LIBS="-lvga"
AC_SUBST(SVGALIB_CFLAGS)
AC_SUBST(SVGALIB_LIBS)
else
@@ -221,7 +221,7 @@
# --with-opengl was explicitly given, so look in that directory
if test "x${ac_with_opengl}" != xauto ; then
OPENGL_CFLAGS="$OPENGL_CFLAGS -I$withval/include"
- OPENGL_LIBS="$OPENGL_CFLAGS -L$withval/lib"
+ OPENGL_LIBS="$OPENGL_LIBS -L$withval/lib"
fi
# save and set CPPFLAGS for coming tests
save_CPPFLAGS="$CPPFLAGS"
@@ -263,7 +263,6 @@
if test "x$HAVE_OPENGL" = xyes; then
AC_DEFINE(HAVE_OPENGL, 1, [Define this if you have OpenGL])
- OPENGL_LIBS="-lGL"
AC_SUBST(OPENGL_CFLAGS)
AC_SUBST(OPENGL_LIBS)
else
@@ -779,9 +778,6 @@
src/ctf/Makefile
src/xatrix/Makefile
src/rogue/Makefile
- data/Makefile
- data/pixmaps/Makefile
- data/baseq2/Makefile
docs/Makefile
docs/ctf/Makefile
quake2.spec