LTTng stands for Linux Trace Toolkit: next generation. It's a modern toolkit for tracing Linux (And now FreeBSD, only userspace now) programs. PR: 216142 Submitted by: mmokhi Reported by: mmokhi Reviewed by: feld, mat Approved by: feld, mat (mentors) Differential Revision: https://reviews.freebsd.org/D9200
45 lines
1.7 KiB
Text
45 lines
1.7 KiB
Text
--- tests/regression/ust/linking/Makefile.am.orig 2017-01-12 17:07:16 UTC
|
|
+++ tests/regression/ust/linking/Makefile.am
|
|
@@ -10,6 +10,8 @@ LIBS =
|
|
demo_builtin_SOURCES = demo.c tp.c tp2.c tp3.c ust_tests_demo.h \
|
|
ust_tests_demo2.h ust_tests_demo3.h
|
|
demo_builtin_LDADD = -llttng-ust
|
|
+demo_builtin_LDFLAGS = \
|
|
+ -L/usr/local/lib
|
|
demo_builtin_CFLAGS = -Werror=old-style-definition
|
|
|
|
# Build a version statically linked to the providers
|
|
@@ -22,12 +24,16 @@ liblttng_ust_provider_ust_tests_demo_sta
|
|
tp2.c ust_tests_demo2.h
|
|
liblttng_ust_provider_ust_tests_demo_static_la_LIBADD = \
|
|
-llttng-ust
|
|
+liblttng_ust_provider_ust_tests_demo_static_la_LDFLAGS = \
|
|
+ -L/usr/local/lib
|
|
|
|
# contains ust_tests_demo3.h provider probes
|
|
liblttng_ust_provider_ust_tests_demo3_static_la_SOURCES = \
|
|
tp3.c ust_tests_demo3.h
|
|
liblttng_ust_provider_ust_tests_demo3_static_la_LIBADD = \
|
|
-llttng-ust
|
|
+liblttng_ust_provider_ust_tests_demo3_static_la_LDFLAGS = \
|
|
+ -L/usr/local/lib
|
|
|
|
demo_static_SOURCES = demo.c
|
|
demo_static_LDADD = liblttng-ust-provider-ust-tests-demo-static.la \
|
|
@@ -68,14 +74,14 @@ liblttng_ust_provider_ust_tests_demo_la_
|
|
tp2.c ust_tests_demo2.h
|
|
liblttng_ust_provider_ust_tests_demo_la_LIBADD = -llttng-ust
|
|
liblttng_ust_provider_ust_tests_demo_la_LDFLAGS = \
|
|
- $(FORCE_SHARED_LIB_OPTIONS)
|
|
+ $(FORCE_SHARED_LIB_OPTIONS) -L/usr/local/lib
|
|
|
|
#contains ust_tests_demo3.h provider probes
|
|
liblttng_ust_provider_ust_tests_demo3_la_SOURCES = \
|
|
tp3.c ust_tests_demo3.h
|
|
liblttng_ust_provider_ust_tests_demo3_la_LIBADD = -llttng-ust
|
|
liblttng_ust_provider_ust_tests_demo3_la_LDFLAGS = \
|
|
- $(FORCE_SHARED_LIB_OPTIONS)
|
|
+ $(FORCE_SHARED_LIB_OPTIONS) -L/usr/local/lib
|
|
|
|
noinst_PROGRAMS += demo
|
|
demo_SOURCES = demo.c ust_tests_demo.h
|