freebsd-ports/net/isc-dhcp40-server/files/patch-dhcpctl::Makefile.dist
Edwin Groothuis 6db5748c1e Maintainer update: isc-dhcp3 splitted to -server, -client, -relay and -devel sub-ports
Step one: convert net/isc-dhcp3 into net/isc-dhcp3-server

PR:		ports/51757
Submitted by:	Cyrille Lefevre <cyrille.lefevre@laposte.net>
2004-01-17 23:09:02 +00:00

79 lines
2.4 KiB
Text

--- dhcpctl/Makefile.dist.orig Mon Apr 28 16:31:57 2003
+++ dhcpctl/Makefile.dist Mon Apr 28 16:24:20 2003
@@ -17,11 +17,11 @@
# http://www.isc.org for more information.
#
-CATMANPAGES = dhcpctl.cat3 omshell.cat1
-SEDMANPAGES = dhcpctl.man3 omshell.man1
+CATMANPAGES = dhcpctl.cat3
+SEDMANPAGES = dhcpctl.man3
SRC = dhcpctl.c callback.c remote.c
OBJ = dhcpctl.o callback.o remote.o
-MAN = dhcpctl.3 omshell.1
+MAN = dhcpctl.3
HDRS = dhcpctl.h
INCLUDES = $(BINDINC) -I$(TOP)/includes
@@ -29,10 +29,7 @@
DHCPCTLLIBS = libdhcpctl.a ../common/libdhcp.a $(BINDLIB) \
../omapip/libomapi.a ../dst/libdst.a
-all: libdhcpctl.a omshell cltest $(CATMANPAGES)
-
-omshell: omshell.o $(DHCPCTLLIBS)
- $(CC) $(DEBUG) $(LFLAGS) -o omshell omshell.o $(DHCPCTLLIBS) $(LIBS)
+all: libdhcpctl.a cltest $(CATMANPAGES)
cltest: cltest.o $(DHCPCTLLIBS)
$(CC) $(DEBUG) $(LFLAGS) -o cltest cltest.o $(DHCPCTLLIBS) $(LIBS)
@@ -43,8 +40,7 @@
$(RANLIB) libdhcpctl.a
install: all $(CATMANPAGES)
- for dir in $(LIBDIR) $(LIBMANDIR) $(INCDIR) $(USRMANDIR) \
- $(USERBINDIR); do \
+ for dir in $(LIBDIR) $(LIBMANDIR) $(INCDIR); do \
foo=""; \
for bar in `echo $(DESTDIR)$${dir} |tr / ' '`; do \
foo=$${foo}/$$bar; \
@@ -64,16 +60,12 @@
$(MANINSTALL) $(MANFROM) $${prefix}.$(MANCAT)$${suffix} $(MANTO) \
$(DESTDIR)$(LIBMANDIR)/$${prefix}$(LIBMANEXT); \
done
- $(INSTALL) omshell $(DESTDIR)$(USERBINDIR)
- $(CHMOD) 755 $(DESTDIR)$(USERBINDIR)/omshell
- $(MANINSTALL) $(MANFROM) omshell.$(MANCAT)1 $(MANTO) \
- $(DESTDIR)$(USRMANDIR)/omshell$(USRMANEXT)
depend:
$(MKDEP) $(INCLUDES) $(PREDEFINES) $(SRC)
clean:
- -rm -f $(OBJ) test.o svtest cltest.o cltest
+ -rm -f $(OBJ) cltest.o cltest
realclean: clean
-rm -f libdhcpctl.a *~ $(CATMANPAGES) $(SEDMANPAGES)
@@ -82,7 +74,7 @@
-rm -f Makefile
links:
- @for foo in $(SRC) $(MAN) omshell.c cltest.c $(HDRS); do \
+ @for foo in $(SRC) $(MAN) cltest.c $(HDRS); do \
if [ ! -b $$foo ]; then \
rm -f $$foo; \
fi; \
@@ -95,12 +87,5 @@
dhcpctl.man3: dhcpctl.3
sed -e "s#ETCDIR#$(ETC)#g" -e "s#DBDIR#$(VARDB)#g" \
-e "s#RUNDIR#$(VARRUN)#g" < dhcpctl.3 >dhcpctl.man3
-
-omshell.cat1: omshell.man1
- nroff -man omshell.man1 >omshell.cat1
-
-omshell.man1: omshell.1
- sed -e "s#ETCDIR#$(ETC)#g" -e "s#DBDIR#$(VARDB)#g" \
- -e "s#RUNDIR#$(VARRUN)#g" < omshell.1 >omshell.man1
# Dependencies (semi-automatically-generated)