freebsd-ports/x11-fm/filerunner/files/patch-aa
Martin Wilke 3e4ed01146 - Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG
- Remove X11BASE support in favor of LOCALBASE or PREFIX
- Use USE_LDCONFIG instead of INSTALLS_SHLIB
- Remove unneeded USE_GCC 3.4+

Thanks to all Helpers:
	Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr,
	ehaupt, nox, itetcu, flz, pav

PR:		116263
Tested on:	pointyhat
Approved by:	portmgr (pav)
2008-04-19 17:56:05 +00:00

17 lines
525 B
Text

--- Makefiles/Makefile.freebsd_gcc.orig Wed Oct 12 17:56:27 2005
+++ Makefiles/Makefile.freebsd_gcc Thu Dec 30 19:21:49 1999
@@ -1,10 +1,10 @@
# Change this if you have this stuff somewhere else.
-TCLINC = /usr/local/lib/tcl8.0
-TKINC = /usr/local/lib/tk8.0
-X11INC = /usr/X11/include
+TCLINC = ${PREFIX}/include/tcl8.4
+TKINC = ${PREFIX}/include/tk8.4
+X11INC = ${LOCALBASE}/include
-CFLAGS = -Wall -fPIC -O3 -I$(TCLINC) -I$(TKINC) -I$(X11INC)
+CFLAGS += -Wall -fPIC -I$(TCLINC) -I$(TKINC) -I$(X11INC)
CC = gcc