freebsd-ports/graphics/ilmbase/files/patch-CMakeLists.txt
Matthias Andree 515db2ed10 Upgrade OpenEXR and ilmbase to 2.2.0.
GCC 4.2 in FreeBSD 8.X/9.X base is now too old to compile OpenEXR, so
GCC-based systems will upgrade to the default ports compiler (GCC 4.7
currently.)

Add two patches to OpenEXR to permit building it in a live system with
the older OpenEXR version installed. Bug report filed to upstream Github
at https://github.com/openexr/openexr/issues/130

Couple OpenEXR more tightly to ilmbase and require its exact .so
version.

Add UPDATING note, and bump PORTREVISION of all dependent ports.

Proto-STAGE hugin-devel, and mark it IGNORE because hugin is newer.

Approved by:	portmgr (implicit for bumping PORTREVISION on unstaged ports)
2014-08-15 20:37:31 +00:00

45 lines
939 B
Text

--- ./CMakeLists.txt.orig 2014-08-10 06:23:56.000000000 +0200
+++ ./CMakeLists.txt 2014-08-15 02:01:33.000000000 +0200
@@ -160,30 +160,30 @@
SET_TARGET_PROPERTIES ( Half
PROPERTIES
- VERSION 12.0.0
+ VERSION 12
SOVERSION 12
)
SET_TARGET_PROPERTIES ( Iex
PROPERTIES
- VERSION 12.0.0
+ VERSION 12
SOVERSION 12
OUTPUT_NAME "Iex${ILMBASE_LIBSUFFIX}"
)
SET_TARGET_PROPERTIES ( Imath
PROPERTIES
- VERSION 12.0.0
+ VERSION 12
SOVERSION 12
OUTPUT_NAME "Imath${ILMBASE_LIBSUFFIX}"
)
SET_TARGET_PROPERTIES ( IlmThread
PROPERTIES
- VERSION 12.0.0
+ VERSION 12
SOVERSION 12
OUTPUT_NAME "IlmThread${ILMBASE_LIBSUFFIX}"
)
SET_TARGET_PROPERTIES ( IexMath
PROPERTIES
- VERSION 12.0.0
+ VERSION 12
SOVERSION 12
OUTPUT_NAME "IexMath${ILMBASE_LIBSUFFIX}"
)
@@ -227,5 +227,5 @@
INSTALL ( FILES
${CMAKE_BINARY_DIR}/IlmBase.pc
DESTINATION
- lib/pkgconfig
+ libdata/pkgconfig
)