freebsd-ports/x11-toolkits/gtk-sharp10/files/patch-configure
Tom McLaughlin 9d37a461bd - Remove libgnomedb# and gda#, libgnomedb and gda are no lobnger part
of Gnome.
- Add support for gtkhtml 3.8
- Correct pkg-plist for gacutil changes with Mono 1.1.9.x
- Include bsd.mono.mk.

Approved by:	ahze (mentor)
Project by:	BSD# <http://www.mono-project.com/Mono:FreeBSD>
2005-11-10 04:21:48 +00:00

137 lines
4.7 KiB
Text

--- configure.orig Mon Jun 6 19:44:13 2005
+++ configure Mon Jun 6 19:46:13 2005
@@ -20851,7 +20851,7 @@
-CFLAGS='-g -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Wshadow -Wpointer-arith -Wno-cast-qual -Wcast-align -Wwrite-strings'
+CFLAGS='-Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Wshadow -Wpointer-arith -Wno-cast-qual -Wcast-align -Wwrite-strings'
# Extract the first word of "pkg-config", so it can be a program name with args.
set dummy pkg-config; ac_word=$2
@@ -21020,7 +21020,7 @@
if test "x$has_mono" = "xtrue"; then
-GACUTIL_FLAGS='/package $(PACKAGE) /gacdir $(DESTDIR)$(prefix)/lib'
+GACUTIL_FLAGS='/package $(PACKAGE) /root $(DESTDIR)$(libdir) /gacdir $(DESTDIR)$(prefix)/lib'
GENERATED_SOURCES=generated/*.cs
# Extract the first word of "mono", so it can be a program name with args.
set dummy mono; ac_word=$2
@@ -22229,6 +22229,107 @@
fi
+GTKHTML_REQUIRED_VERSION=3.7.0
+
+ succeeded=no
+
+ if test -z "$PKG_CONFIG"; then
+ # Extract the first word of "pkg-config", so it can be a program name with args.
+set dummy pkg-config; ac_word=$2
+echo "$as_me:$LINENO: checking for $ac_word" >&5
+echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
+if test "${ac_cv_path_PKG_CONFIG+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
+ case $PKG_CONFIG in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_PKG_CONFIG="$PKG_CONFIG" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+ ac_cv_path_PKG_CONFIG="$as_dir/$ac_word$ac_exec_ext"
+ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+done
+
+ test -z "$ac_cv_path_PKG_CONFIG" && ac_cv_path_PKG_CONFIG="no"
+ ;;
+esac
+fi
+PKG_CONFIG=$ac_cv_path_PKG_CONFIG
+
+if test -n "$PKG_CONFIG"; then
+ echo "$as_me:$LINENO: result: $PKG_CONFIG" >&5
+echo "${ECHO_T}$PKG_CONFIG" >&6
+else
+ echo "$as_me:$LINENO: result: no" >&5
+echo "${ECHO_T}no" >&6
+fi
+
+ fi
+
+ if test "$PKG_CONFIG" = "no" ; then
+ echo "*** The pkg-config script could not be found. Make sure it is"
+ echo "*** in your path, or set the PKG_CONFIG environment variable"
+ echo "*** to the full path to pkg-config."
+ echo "*** Or see http://www.freedesktop.org/software/pkgconfig to get pkg-config."
+ else
+ PKG_CONFIG_MIN_VERSION=0.9.0
+ if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
+ echo "$as_me:$LINENO: checking for libgtkhtml-3.8 >= $GTKHTML_REQUIRED_VERSION" >&5
+echo $ECHO_N "checking for libgtkhtml-3.8 >= $GTKHTML_REQUIRED_VERSION... $ECHO_C" >&6
+
+ if $PKG_CONFIG --exists "libgtkhtml-3.8 >= $GTKHTML_REQUIRED_VERSION" ; then
+ echo "$as_me:$LINENO: result: yes" >&5
+echo "${ECHO_T}yes" >&6
+ succeeded=yes
+
+ echo "$as_me:$LINENO: checking GTKHTML_DEPENDENCIES_CFLAGS" >&5
+echo $ECHO_N "checking GTKHTML_DEPENDENCIES_CFLAGS... $ECHO_C" >&6
+ GTKHTML_DEPENDENCIES_CFLAGS=`$PKG_CONFIG --cflags "libgtkhtml-3.8 >= $GTKHTML_REQUIRED_VERSION"`
+ echo "$as_me:$LINENO: result: $GTKHTML_DEPENDENCIES_CFLAGS" >&5
+echo "${ECHO_T}$GTKHTML_DEPENDENCIES_CFLAGS" >&6
+
+ echo "$as_me:$LINENO: checking GTKHTML_DEPENDENCIES_LIBS" >&5
+echo $ECHO_N "checking GTKHTML_DEPENDENCIES_LIBS... $ECHO_C" >&6
+ GTKHTML_DEPENDENCIES_LIBS=`$PKG_CONFIG --libs "libgtkhtml-3.8 >= $GTKHTML_REQUIRED_VERSION"`
+ echo "$as_me:$LINENO: result: $GTKHTML_DEPENDENCIES_LIBS" >&5
+echo "${ECHO_T}$GTKHTML_DEPENDENCIES_LIBS" >&6
+ else
+ GTKHTML_DEPENDENCIES_CFLAGS=""
+ GTKHTML_DEPENDENCIES_LIBS=""
+ ## If we have a custom action on failure, don't print errors, but
+ ## do set a variable so people can do so.
+ GTKHTML_DEPENDENCIES_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libgtkhtml-3.8 >= $GTKHTML_REQUIRED_VERSION"`
+
+ fi
+
+
+
+ else
+ echo "*** Your version of pkg-config is too old. You need version $PKG_CONFIG_MIN_VERSION or newer."
+ echo "*** See http://www.freedesktop.org/software/pkgconfig"
+ fi
+ fi
+
+ if test $succeeded = yes; then
+ enable_gtkhtml=yes
+ else
+ enable_gtkhtml=no
+ fi
+
+if test "x$enable_gtkhtml" = "xyes"; then
+GTKHTML_VERSION=3.8
+GTKHTML_SOVERSION=18
+else
GTKHTML_REQUIRED_VERSION=3.6.0
succeeded=no
@@ -22639,7 +22740,7 @@
fi
fi
fi
-
+fi
if test "x$enable_gnome" = "xyes"; then