freebsd-ports/devel/omniORB/files/patch-aj
Patrick Li abff247a41 Update to 3.0.5
PR:		ports/41267
Submitted by:	Alex Hayward <xelah@xelah.com>
Approved by:	maintainer
2002-08-08 18:02:22 +00:00

58 lines
1.5 KiB
Text

--- mk/platforms/x86_freebsd_4.0.mk.orig Thu Jul 25 16:36:31 2002
+++ mk/platforms/x86_freebsd_4.0.mk Thu Jul 25 16:38:55 2002
@@ -10,7 +10,7 @@
#
# You must set a path to a Python 1.5.2 interpreter.
-#PYTHON = /usr/local/bin/python
+PYTHON = ${PYTHON_CMD}
#
@@ -25,12 +25,13 @@
#
AR = ar cq
+MKDIRHIER= ${MKDIR}
CPP = /usr/libexec/cpp
-CXX = g++
+CXX ?= g++
CXXMAKEDEPEND += -D__cplusplus -D__GNUG__ -D__GNUC__
-CXXDEBUGFLAGS = -O2
+CXXDEBUGFLAGS ?= -O2
CXXLINK = $(CXX) -pthread -s
CXXLINKOPTIONS = $(CXXDEBUGFLAGS) $(CXXOPTIONS)
@@ -39,14 +40,14 @@
EgcsMajorVersion = 1
EgcsMinorVersion = 1 # This is actually a post-1.0 egcs snapshot.
-CC = gcc
+CC ?= gcc
CMAKEDEPEND += -D__GNUC__
-CDEBUGFLAGS = -O2
+CDEBUGFLAGS ?= -O2
CLINK = $(CC)
CLINKOPTIONS = $(CDEBUGFLAGS) $(COPTIONS)
-INSTALL = install -c
+INSTALL = ${BSD_INSTALL} -c
IMPORT_CPPFLAGS += -D__x86__ -D__freebsd__ -D__OSVERSION__=4
@@ -72,10 +73,10 @@
# Default location of the omniORB configuration file [falls back to this if
# the environment variable OMNIORB_CONFIG is not set] :
-OMNIORB_CONFIG_DEFAULT_LOCATION = /etc/omniORB.cfg
+OMNIORB_CONFIG_DEFAULT_LOCATION = ${PREFIX}/etc/omniORB.cfg
# Default directory for the omniNames log files.
-OMNINAMES_LOG_DEFAULT_LOCATION = /var/omninames
+OMNINAMES_LOG_DEFAULT_LOCATION = /var/log/omninames
# Uncomment the following if you want all utils and examples build in
# this tree to statically linke with the omniORB libraries.