c39fe019af
Update patch for nginx.conf. Rewrote pkg-plist as describe in FreeBSD Porter's Handbook, section 7.3 for fix package installation. (*) Problem found by: Denis Shaposhnikov dsh at vlink dot ru (*) <ChangeLog> *) Change: now the paths specified in the "include", "auth_basic_user_file", "perl_modules", "ssl_certificate", "ssl_certificate_key", and "ssl_client_certificate" directives are relative to directory of nginx configuration file nginx.conf, but no to nginx prefix directory. *) Change: the --sysconfdir=PATH option in configure was canceled. *) Change: the special make target "upgrade1" was defined for online upgrade of 0.1.x versions. *) Feature: the "server_name" and "valid_referers" directives support regular expressions. *) Feature: the "server" directive in the "upstream" context supports the "backup" parameter. *) Feature: the ngx_http_perl_module supports the $r->discard_request_body. *) Feature: the "add_header Last-Modified ..." directive changes the "Last-Modified" response header line. *) Bugfix: if an response different than 200 was returned to an request with body and connection went to the keep-alive state after the request, then nginx returned 400 for the next request. *) Bugfix: a segmentation fault occurred in worker process if invalid address was set in the "auth_http" directive. *) Bugfix: now nginx uses default listen backlog value 511 on all platforms except FreeBSD. Thanks to Jiang Hong. *) Bugfix: a worker process may got caught in an endless loop, if an "server" inside "upstream" block was marked as "down"; bug appeared in 0.6.6. *) Bugfix: now Solaris sendfilev() is not used to transfer the client request body to FastCGI-server via the unix domain socket. </ChangeLog>
32 lines
762 B
Text
32 lines
762 B
Text
|
|
$FreeBSD$
|
|
|
|
--- conf/nginx.conf.orig Thu Jan 18 10:08:18 2007
|
|
+++ conf/nginx.conf Thu Jun 14 12:57:52 2007
|
|
@@ -33,7 +33,7 @@
|
|
#gzip on;
|
|
|
|
server {
|
|
- listen 80;
|
|
+ listen %%HTTP_PORT%%;
|
|
server_name localhost;
|
|
|
|
#charset koi8-r;
|
|
@@ -41,7 +41,7 @@
|
|
#access_log logs/host.access.log main;
|
|
|
|
location / {
|
|
- root html;
|
|
+ root %%PREFIX%%/www/nginx;
|
|
index index.html index.htm;
|
|
}
|
|
|
|
@@ -51,7 +51,7 @@
|
|
#
|
|
error_page 500 502 503 504 /50x.html;
|
|
location = /50x.html {
|
|
- root html;
|
|
+ root %%PREFIX%%/www/nginx-dist;
|
|
}
|
|
|
|
# proxy the PHP scripts to Apache listening on 127.0.0.1:80
|