freebsd-ports/x11-fm/rox-filer/files/patch-ROX-Filer_src_Makefile.in
Kurt Jaeger 2121e5e429 x11-fm/rox-filer: add missing dependencies and clean Makefile
- Regenerate patch files with make makepatch.
- Remove useless assignment to DISTNAME.
- Add a lib dependency on print/freetype2
- Add a lib dependency on x11-fonts/fontconfig
- Add LICENSE= GPLv2+
- Move USES ahead of USE_*
- Add gettext-runtime:build to the USES variable
- Add ice to the variable USE_XORG and sort the corresponding list
- Add cairo and gdkpixbuf2 to the variable USE_GNOME
- Reindent the lines of the target post-configure
- Split a line of the target do-install
- Replace the use of ${CHMOD} 755 in Makefile
  with the use of @(,,755) in pkg-plist

PR:		230710
Submitted by:	Samy Mahmoudi <samy.mahmoudi@gmail.com>
Approved by:	olgeni (maintainer)
2018-08-17 18:06:43 +00:00

23 lines
706 B
Text

--- ROX-Filer/src/Makefile.in.orig 2011-10-09 14:31:59 UTC
+++ ROX-Filer/src/Makefile.in
@@ -7,7 +7,7 @@ CC = @CC@
.SUFFIXES: .c .o
PKG_CONFIG = @PKG_CONFIG@
-LIBS = @LIBS@ @LFS_LDFLAGS@ -lICE -lSM
+LIBS = @LIBS@ @LFS_LDFLAGS@ -lICE -lSM -linotify
#PROF = -fprofile-arcs -pg
PKG_CONFIG_FLAGS=
@@ -47,10 +47,7 @@ OBJECTS = abox.o action.o appinfo.o appm
${PROG}: ${OBJECTS}
${CC} -o "${PROG}" ${OBJECTS} ${LDFLAGS}
mv "${PROG}" "${PLATFORM_DIR}"
- -(cd "${PLATFORM_DIR}" && \
- objcopy --only-keep-debug ROX-Filer ROX-Filer.dbg && \
- strip ROX-Filer && \
- objcopy --add-gnu-debuglink=ROX-Filer.dbg ROX-Filer)
+ -(cd "${PLATFORM_DIR}" && strip ROX-Filer)
clean:
rm -f *.o Makefile.bak