freebsd-ports/editors/openoffice-3-devel/files/patch-i77615
Maho Nakata 29381266f8 0. update to SRC680_m213.
1. A fix for patch-i76141, missing libxml2 patch. libxmlsec part
 is now reordered correctly [1].
2. Remove patch-i65462 and add patch from i76159 instead [1].
3. DISTDIR is moved to openoffice.org2 instead of openoffice.org2.0 [1].
4. FreeBSD bridge part should sync with sixtyfour11. patch-i76969 [1].
5. unxfbsd.mk: sync with newer unxlngi6.mk. patch-i76969 [1].
6. Add a new knob WITH_VBA, enables VBA interop.
7. Use gcc4.2 for build.
8. Remove WITH_GNUGCJ knob for while.
9. Drop amd64 for while.

Submitted by:	jkim [1]
2007-05-26 21:45:56 +00:00

57 lines
1.5 KiB
Text

For FreeBSD, libxslt builds libraries as libxslt.so.2 or something
like that. Following patch fixes this.
Index: libxslt/libxslt-1.1.16.patch
===================================================================
RCS file: /cvs/external/libxslt/libxslt-1.1.16.patch,v
retrieving revision 1.2
diff -u -r1.2 libxslt-1.1.16.patch
--- libxslt/libxslt-1.1.16.patch 10 May 2007 13:10:07 -0000 1.2
+++ libxslt/libxslt-1.1.16.patch 20 May 2007 02:35:31 -0000
@@ -108,3 +108,46 @@
!
! exit 0
+*** misc/libxslt-1.1.16/ltmain.sh Sun Feb 12 09:50:49 2006
+--- misc/build/libxslt-1.1.16/ltmain.sh Sun May 20 11:34:29 2007
+***************
+*** 3192,3200 ****
+ revision="$number_revision"
+ ;;
+ freebsd-aout|freebsd-elf|sunos)
+! current="$number_major"
+! revision="$number_minor"
+! age="0"
+ ;;
+ irix|nonstopux)
+ current=`expr $number_major + $number_minor - 1`
+--- 3192,3200 ----
+ revision="$number_revision"
+ ;;
+ freebsd-aout|freebsd-elf|sunos)
+! current=`expr $number_major + $number_minor`
+! age="$number_minor"
+! revision="$number_revision"
+ ;;
+ irix|nonstopux)
+ current=`expr $number_major + $number_minor - 1`
+***************
+*** 3267,3274 ****
+ ;;
+
+ freebsd-elf)
+! major=".$current"
+! versuffix=".$current";
+ ;;
+
+ irix | nonstopux)
+--- 3267,3274 ----
+ ;;
+
+ freebsd-elf)
+! major=.`expr $current - $age`
+! versuffix="$major.$age.$revision"
+ ;;
+
+ irix | nonstopux)
+