freebsd-ports/graphics/fotoxx/files/patch-f.meta.cc
Matthias Andree 92500c08eb Unbreak and upgrade to new upstream release 14.02.2.
Based on a patch to upgrade to 14.01.1 by Rainer Hurling,
based on a patch to upgrade to 13.03.1 by Rod Person.

Rainer's changes:
- new mastersite; 2nd mastersites contents has to be updated
- unbreak the port
- modernize LIB_DEPENDS
- support STAGE_DIR
- strip bin/fotoxx
- correct usage of desktop-file-utils
- update URL in pkg-descr
- update pkg-plist

Committer's changes:
- work around fetch(1)/nginx incompatibility making fetch commands with
  unmerged fix r261263 (and ancestors) unable to fetch from the primary
  site.
- add USES=pkgconfig
- add mirror sites
- fix installation of manfile
- fix paths in desktop file
- stop using xdg-desktop-menu for now, breaks the build and does not
  appear to be required

PR:		ports/177643
Submitted by:	Rod Person, Rainer Hurling
2014-02-07 01:01:37 +00:00

46 lines
1.5 KiB
C++

--- ./f.meta.cc.orig 2014-02-05 20:42:34.000000000 +0100
+++ ./f.meta.cc 2014-02-06 10:32:37.000000000 +0100
@@ -23,6 +23,7 @@
#define EX extern // enable extern declarations
#include "fotoxx.h"
+#include <sys/wait.h>
/**************************************************************************
@@ -5786,7 +5787,7 @@
strcpy(sxrec.size,"null");
if (! sxrec.tags)
- sxrec.tags = strdupz("null"tagdelimB,0,"search-index");
+ sxrec.tags = strdupz("null" tagdelimB,0,"search-index");
if (! sxrec.capt)
sxrec.capt = strdupz("null",0,"search-index");
@@ -5993,7 +5994,7 @@
if (sxrec->tags)
nn = fprintf(fid2,"tags: %s\n",sxrec->tags); // tags rec.
- else nn = fprintf(fid2,"tags: null"tagdelimB"\n");
+ else nn = fprintf(fid2,"tags: null" tagdelimB"\n");
if (! nn) goto file_err;
if (sxrec->capt)
@@ -6147,7 +6148,7 @@
strcpy(sxrec.size,"null");
if (! sxrec.tags)
- sxrec.tags = strdupz("null"tagdelimB,0,"search-index");
+ sxrec.tags = strdupz("null" tagdelimB,0,"search-index");
if (! sxrec.capt)
sxrec.capt = strdupz("null",0,"search-index");
@@ -6259,7 +6260,7 @@
if (sxrec->tags)
nn = fprintf(fid,"tags: %s\n",sxrec->tags); // tags rec.
- else nn = fprintf(fid,"tags: null"tagdelimB"\n");
+ else nn = fprintf(fid,"tags: null" tagdelimB"\n");
if (! nn) goto file_err;
if (sxrec->capt)