freebsd-ports/security/srp/files/patch-telnet::telnetd::sys_term.c
Jacques Vidrine c49659f44d Fix broken pkg-plist: the docs snuck in there, but they are also added
by the port at build-time.

Fix for FreeBSD-CURRENT:
= Remove use of malloc.h
= A fragment of this port actually provides its own prototype for time(), and
  probably only gets it right on DEC and HP systems.

PR:		ports/34183
Reported by:	Trish Lynch <trish@bsdunix.net>
2002-01-22 22:40:36 +00:00

21 lines
544 B
C

--- telnet/telnetd/sys_term.c.orig Tue Jul 31 01:27:05 2001
+++ telnet/telnetd/sys_term.c Tue Jan 22 16:31:27 2002
@@ -111,6 +111,9 @@
# else
char wtmpf[] = "/usr/adm/wtmp";
# endif
+#if defined(__FreeBSD__)
+#define UTMP_FILE _PATH_UTMP
+#endif
# ifdef UTMP_FILE
char utmpf[] = UTMP_FILE;
# else
@@ -1473,7 +1476,7 @@
{
register int i;
int syncpipe[2];
-#if defined(OSF) || defined(ultrix) || defined(__hpux)
+#if defined(OSF) || defined(ultrix) || defined(__hpux) || defined(__FreeBSD__)
time_t time();
#else
long time();