freebsd-ports/lang/gnat-gcc34/files/patch-gcc-Makefile.in
Boris Samorodov 635ff557f5 - improved handling of include paths in the GCC build process; [1]
- proper care is taken that only the bootstrap compiler is used  [1]
  (silences core dump messages in configure);
- bump PORTREVISION.   [1]

PR:		104301  [2]
Submitted by:	Vaclav Haisman <v.haisman at sh.cvut.cz>  [2]
		Karel Miklav <karel at lovetemple.net> (maintainer)  [1]
2006-10-31 23:11:33 +00:00

20 lines
718 B
Text
Raw Blame History

This file contains invisible Unicode characters

This file contains invisible Unicode characters that are indistinguishable to humans but may be processed differently by a computer. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

--- gcc/Makefile.in.orig Wed Oct 25 18:03:23 2006
+++ gcc/Makefile.in Wed Oct 25 18:05:34 2006
@@ -710,7 +710,7 @@
$(CFLAGS) $(INTERNAL_CFLAGS) $(COVERAGE_FLAGS) $(WARN_CFLAGS) $(XCFLAGS) @DEFS@
# Likewise.
-ALL_CPPFLAGS = $(CPPFLAGS) $(X_CPPFLAGS) $(T_CPPFLAGS)
+ALL_CPPFLAGS = $(INCLUDES) $(CPPFLAGS) $(X_CPPFLAGS) $(T_CPPFLAGS)
# Build and host support libraries. FORBUILD is either
# .. or ../$(build_alias) depending on whether host != build.
@@ -758,7 +758,7 @@
-I$(srcdir)/../include @INCINTL@
.c.o:
- $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) $(INCLUDES) $< $(OUTPUT_OPTION)
+ $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) $< $(OUTPUT_OPTION)
#
# Support for additional languages (other than C).