freebsd-ports/games/q2pro/files/patch-build__pre.mk
Alexey Dokuchaev e66ecce526 - Fix run-time crash after png_set_gray_1_2_4_to_8() was renamed to
png_set_expand_gray_1_2_4_to_8() in the PNG library
- Make sure that software renderer works in !i386 build mode
- Remove bogus compile options from the CFLAGS; default CFLAGS are
  already being respected
- Simplify OPTIONS: do not force users to select at least one of the
  client or server, it is not very useful and just complicate things
- Report correct SVN revision number in the version string
- Spell ``renderer'' correctly in the option descriptions
2016-04-28 18:02:18 +00:00

26 lines
767 B
Makefile

--- build/pre.mk.orig Sun Feb 4 16:13:21 2007
+++ build/pre.mk Sun Feb 4 16:27:54 2007
@@ -25,7 +25,7 @@ CFLAGS+=-g
LDFLAGS+=-g
else
#CFLAGS += -march=i686 -msse2 -mfpmath=sse -O2 -fno-strict-aliasing -DNDEBUG
-CFLAGS+=-ffloat-store -O2 -fno-strict-aliasing -DNDEBUG
+CFLAGS+= -DNDEBUG
LDFLAGS+=-s
endif
@@ -48,10 +48,10 @@ SRCFILES_WIN32=#blank
ASMFILES_WIN32=#blank
VPATH_WIN32=$(RCDIR)
-DATADIR?=/usr/share/games/quake2
-LIBDIR?=/usr/lib/games/quake2
-CFLAGS_LINUX=-DDATADIR='"$(DATADIR)"' -DLIBDIR='"$(LIBDIR)"'
-LDFLAGS_LINUX=#blank
+DATADIR?=$(Q2DIR)
+LIBDIR?=$(PREFIX)/lib/q2pro
+CFLAGS_LINUX=-I$(LOCALBASE)/include -DDATADIR='"$(DATADIR)"' -DLIBDIR='"$(LIBDIR)"'
+LDFLAGS_LINUX=-L$(LOCALBASE)/lib
SRCFILES_LINUX=#blank
ASMFILES_LINUX=#blank