freebsd-ports/security/pft/files/patch-pjlsession.cpp
Jean-Yves Lefort 5dfbb203a1 - Update to 1.3 [1]
- Respect ${CXX} and ${CXXFLAGS}
- Refactor pkg-plist as PLIST_FILES

PR:		ports/81357
Submitted by:	maintainer
2005-05-22 17:35:42 +00:00

11 lines
359 B
C++

--- pjlsession.cpp.orig Sun May 22 14:06:23 2005
+++ pjlsession.cpp Sun May 22 14:06:52 2005
@@ -871,7 +871,7 @@
#endif //_DEBUG
throw ExInvalid();
} else {
- snprintf(numb,49,"%lu",statbuf.st_size);
+ snprintf(numb,49,"%llu",statbuf.st_size);
connection.clear();
connection.sendbuf.set(PJL_START);
connection.sendbuf.append(PJL_FSDOWNLOAD);