- add option to build for Nagios3 (default) and Nagios4 - add stage support - remove livecheck patches (broker was removed) Changes: ======== 1.2.4 o nagios4 livestatus support 1.2.4b1 o New header for limiting the execution time of a query o FIX: Parse state of downtime notification log entries correctly o FIX: Limit the number of lines read from a single logfile o FIX: Fix semantics of columns num_services_hard_* 1.2.3.i7 o livedump: new option to mark the mode at the beginning of the dump and documentation fixes o FIX: Fixed incorrect starttime of table statehist entries o FIX: Availability no longer showes incorrect entries when only one logfile exists o FIX: Fixed missing entries in log file and availability view 1.2.3.i5 o Removed "livecheck". It never was really stable. Nagios4 has something similar built in. o table statehist: no longer computes an unmonitored state for hosts and services on certain instances. (showed up as no hosts/services in the multisite gui) o table statehist: fixed SIGSEGV chance on larger queries 1.2.3.i3 o FIX: check_mk snmp checks with a custom check interval no longer have an incorrect staleness value 1.2.3.i2 o new service column staleness: indicator for outdated service checks o new host column staleness: indicator for outdated host checks 1.2.3i1 o Table statehist: Improved detection of vanished hosts and services. Now able to detect and remove nonsense check plugin output o FIX: able to handle equal comment_id between host and service o livestatus.log: show utf-8 decoding problems only with debug logging >=2 o livestatus: fixed incorrect output formatting of comments_with_info column 1.2.2p3 o livestatus: fixed incorrect output formatting of comments_with_info column o table statehist: fixed memory leak
27 lines
882 B
Text
27 lines
882 B
Text
--- ./src/Makefile.in.orig 2014-02-10 10:54:03.000000000 +0100
|
|
+++ ./src/Makefile.in 2014-02-20 22:47:49.000000000 +0100
|
|
@@ -260,7 +260,7 @@
|
|
am__quote = @am__quote@
|
|
am__tar = @am__tar@
|
|
am__untar = @am__untar@
|
|
-bindir = @bindir@
|
|
+bindir = $(pkglibdir)
|
|
build_alias = @build_alias@
|
|
builddir = @builddir@
|
|
datadir = @datadir@
|
|
@@ -366,15 +366,6 @@
|
|
test -z "$$list2" || { \
|
|
echo " $(INSTALL_DATA) $$list2 '$(DESTDIR)$(pkglibdir)'"; \
|
|
$(INSTALL_DATA) $$list2 "$(DESTDIR)$(pkglibdir)" || exit $$?; }
|
|
- @$(POST_INSTALL)
|
|
- @list='$(pkglib_LIBRARIES)'; test -n "$(pkglibdir)" || list=; \
|
|
- for p in $$list; do \
|
|
- if test -f $$p; then \
|
|
- $(am__strip_dir) \
|
|
- echo " ( cd '$(DESTDIR)$(pkglibdir)' && $(RANLIB) $$f )"; \
|
|
- ( cd "$(DESTDIR)$(pkglibdir)" && $(RANLIB) $$f ) || exit $$?; \
|
|
- else :; fi; \
|
|
- done
|
|
|
|
uninstall-pkglibLIBRARIES:
|
|
@$(NORMAL_UNINSTALL)
|