34 lines
1.1 KiB
Text
34 lines
1.1 KiB
Text
|
|
$FreeBSD$
|
|
|
|
--- setup.py.orig Tue May 22 19:02:54 2001
|
|
+++ setup.py Mon May 28 19:58:15 2001
|
|
@@ -86,6 +86,16 @@
|
|
|
|
|
|
#----------------------------------------------------------------------
|
|
+# Check for some environment variables
|
|
+#----------------------------------------------------------------------
|
|
+
|
|
+try: gtk_config = os.environ['GTK_CONFIG']
|
|
+except KeyError: gtk_config = 'gtk-config'
|
|
+
|
|
+try: sys_libs = string.split(os.environ['LIBS'])
|
|
+except KeyError: sys_libs = []
|
|
+
|
|
+#----------------------------------------------------------------------
|
|
# Check for build flags on the command line
|
|
#----------------------------------------------------------------------
|
|
|
|
@@ -229,9 +239,10 @@
|
|
]
|
|
libdirs = []
|
|
libs = []
|
|
+ libs.extend(sys_libs)
|
|
|
|
cflags = os.popen(WX_CONFIG + ' --cflags', 'r').read()[:-1] + ' ' + \
|
|
- os.popen('gtk-config --cflags', 'r').read()[:-1]
|
|
+ os.popen(gtk_config + ' --cflags', 'r').read()[:-1]
|
|
cflags = string.split(cflags)
|
|
|
|
lflags = os.popen(WX_CONFIG + ' --libs', 'r').read()[:-1]
|