freebsd-ports/audio/stymulator/files/patch-stsoundlib_Makefile
Mathieu Arnold 9fa9eb9ac7 Cleanup patches, a* categories.
Rename them to follow the make makepatch naming, and regenerate them.

With hat:	portmgr
Sponsored by:	Absolight
2016-07-26 16:51:15 +00:00

38 lines
864 B
Text

--- stsoundlib/Makefile.orig 2016-07-26 16:04:42 UTC
+++ stsoundlib/Makefile
@@ -1,28 +1,28 @@
-CC = g++
+CXX ?= g++
AR = ar cr
RM = rm -f
LIB = digidrum.o Ymload.o Ym2149Ex.o YmMusic.o YmUserInterface.o
-CFLAGS = -Wall
+CFLAGS ?= -Wall
libym.a: $(LIB)
$(AR) libym.a $(LIB)
digidrum.o: digidrum.cpp YmTypes.h
- $(CC) -c digidrum.cpp
+ $(CXX) $(CXXFLAGS) -c digidrum.cpp
Ym2149Ex.o: Ym2149Ex.cpp Ym2149Ex.h YmTypes.h
- $(CC) -c Ym2149Ex.cpp
+ $(CXX) $(CXXFLAGS) -c Ym2149Ex.cpp
Ymload.o: Ymload.cpp YmMusic.h lzh/lzh.h
- $(CC) -c Ymload.cpp
+ $(CXX) $(CXXFLAGS) -c Ymload.cpp
YmMusic.o: YmMusic.cpp YmMusic.h
- $(CC) -c YmMusic.cpp
+ $(CXX) $(CXXFLAGS) -c YmMusic.cpp
YmUserInterface.o: YmUserInterface.cpp StSoundLibrary.h YmMusic.h
- $(CC) -c YmUserInterface.cpp
+ $(CXX) $(CXXFLAGS) -c YmUserInterface.cpp
clean:
$(RM) *~ *.o *.a