Dozens of KDE apps are getting new releases from KDE’s release service. New features, usability improvements, re-designs and bug fixes all contribute to helping boost your productivity and making this new batch of applications more efficient and pleasant to use. Full announcement: https://kde.org/announcements/releases/2020-08-apps-update/
46 lines
1.6 KiB
Text
46 lines
1.6 KiB
Text
--- CMakeLists.txt.orig 2020-08-13 17:06:59 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -81,24 +81,27 @@ set_package_properties("libssh" PROPERTIES
|
|
PURPOSE "Needed to build VNC+SSH tunnel support "
|
|
)
|
|
|
|
-# Needs porting
|
|
-find_program(FREERDP_EXECUTABLE xfreerdp)
|
|
-if(FREERDP_EXECUTABLE)
|
|
- set(FREERDP_FOUND true) # mark the package found
|
|
- set(FREERDP_EXECUTABLE_FOUND true)
|
|
-endif(FREERDP_EXECUTABLE)
|
|
+option(WITH_FREERDP OFF)
|
|
+if (WITH_FREERDP)
|
|
+ # Needs porting
|
|
+ find_program(FREERDP_EXECUTABLE xfreerdp)
|
|
+ if(FREERDP_EXECUTABLE)
|
|
+ set(FREERDP_FOUND true) # mark the package found
|
|
+ set(FREERDP_EXECUTABLE_FOUND true)
|
|
+ endif(FREERDP_EXECUTABLE)
|
|
|
|
-# dud to allow the dep showing up in feature summary.
|
|
-# note that this must be after _FOUND is set so it doesn't incorrectly
|
|
-# set the metadata to not-found.
|
|
-find_package(freerdp QUIET)
|
|
+ # dud to allow the dep showing up in feature summary.
|
|
+ # note that this must be after _FOUND is set so it doesn't incorrectly
|
|
+ # set the metadata to not-found.
|
|
+ find_package(freerdp QUIET)
|
|
|
|
-set_package_properties(freerdp PROPERTIES
|
|
- DESCRIPTION "A free Remote Desktop Protocol (RDP) Implementation"
|
|
- URL "https://www.freerdp.com/"
|
|
- PURPOSE "The xfreerdp binary is needed for RDP support in KRDC (at runtime)"
|
|
- TYPE RUNTIME
|
|
-)
|
|
+ set_package_properties(freerdp PROPERTIES
|
|
+ DESCRIPTION "A free Remote Desktop Protocol (RDP) Implementation"
|
|
+ URL "https://www.freerdp.com/"
|
|
+ PURPOSE "The xfreerdp binary is needed for RDP support in KRDC (at runtime)"
|
|
+ TYPE RUNTIME
|
|
+ )
|
|
+endif()
|
|
|
|
include_directories(
|
|
${CMAKE_CURRENT_SOURCE_DIR}
|